1. Apex's Avatar
    Hi guys,

    Firstly, my apologies if this has been covered before. I did use the search feature but wasn't able to find anything relating to this specific issue.

    So, my iPhone has recently developed a very unusual issue, and that is when I'm on silent/vibrate mode and I get a call, instead of vibrating it plays the Harp ringtone. This obviously kinda defeats the purpose of having it on vibrate and it's rather annoying when it goes off at work.

    When it's on regular ringer mode it plays the correct ringtone just fine, but as soon as it's switched to vibrate and gets a call it defaults to Harp. I know the vibrator's not broken, as I still get vibrations when in vibration mode and I receive emails or texts, but simply not so for phone calls.

    Has anyone else encountered this before or know of a solution to this? I'm guessing something I installed on it caused this but I've no idea what and am not particularly in the mood to go about restoring the firmware - not this close to the release of OS 2.0.

    I'm currently running on 1.1.3 jailbroken and unlocked on t-mobile. Again, if this has been covered before, my apologies. Simply direct me to a thread on this and i'll be right on my way, but if not, any insights anyone may have would be greatly appreciated. Thanks!
    Last edited by Apex; 2008-07-06 at 02:44 PM.
    2008-07-06 02:38 PM
  2. Poseidon79's Avatar
    Welcome to MMi! The first thing to try when having a sound issue is to reset all settings. Settings > General > Reset > Reset all settings. If this doesn't work you may have to restore as the programming may have gotten messed up.
    2008-07-06 05:23 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.