1. PontiacRacing_06's Avatar
    My unlocked and jailbroken iPhone froze up on me 2 nights ago and I was told the only thing to do was restore so I went into iTunes and tried restoring back to 1.1.1 which is what was originally shipped with the phone with my ISPF file I have for the firmware and when going to restore it extracts the software package and when it goes to prepare the iphone for restore the white screen comes on the phone for a second then it goes off back to an apple screen with the circle moving saying its thinking and an unknown error (4) cannot restore comes up on iTunes. What can I do to get my iphone back up and working please? Any help would be greatly appreciated thanks
    2007-12-21 03:52 PM
  2. phoenixfire425's Avatar
    I had the same problem at one point.

    What i did is i re-downloaded the 1.1.1 FW and then did a shift+restore from itunes. and then it gave me the -1015 error.. (its a good thing) rebooted and then i used ibricker to start the phone.

    if that does not work try going to 1.0.2 see if that helps.

    if that does not work.. well pst back.
    2007-12-21 06:10 PM
  3. PontiacRacing_06's Avatar
    Thanks for the reply, I downloaded both the 1.0.2 FW and the 1.1.1 FW from modmyi here and did the Shift/Restore in iTunes and I'm still getting that unknown error and the phone goes white for a second like it wants to restore but then goes right back to the apple screen and the restore fails. However when I go to downgrade to 1.0.2 I get a different unknown error as its unknown error (6) instead of unknown error (4) What else should I try?

    Also I have iBricker on my PC but I do not know how to boot the iPhone from it, how did you get iBricker to boot your iPhone or does it only work with 1.0.2 FW? Thanks again
    Last edited by PontiacRacing_06; 2007-12-21 at 06:30 PM. Reason: Automerged Doublepost
    2007-12-21 06:30 PM
  4. Mage333's Avatar
    So i guess u can open the iphone and connect it to itunes? Have u tried putting it in restore mode?
    2007-12-21 08:18 PM
  5. PontiacRacing_06's Avatar
    I'm actually unable to open the iphone and connect it to iTunes the only way that it connects to iTunes is when I put the iPhone into Restore mode and try doing the Shift/Restore to it but it won't restore as it keeps giving me those errors. What else can I try please?
    2007-12-21 08:36 PM
  6. Mage333's Avatar
    Hey i found this on Apple's website, hope it helps http://docs.info.apple.com/article.html?artnum=307120
    2007-12-22 03:28 AM
  7. PontiacRacing_06's Avatar
    I got my iPhone restored and working again but I'm on 1.0.2 now but I'm going to go through the upgrade process to get it unlocked and upgraded to 1.1.1 again like I orignally had, thanks for all the help I appreciate it
    2007-12-22 04:54 AM
  8. Mia_antoinette's Avatar
    Okay i am new to this site and iphone im general , Here is my dilemma I got an unlocked iphone running on 1.1.4 i recently updated the software via winpwn 2.5 to 2.0.2 . Everything ran smoothly except cydia kept giving me an error message that i needed to add more sources which i did by the way and it still gave me an error message , but everything else ran fine. I accidently unistalled cydia after that my keypad wouldnt let me dial then eventually it just stopped on me so i restored it with itunes to no avail because i just got the boot up screen with a constant little circle that vibed every 30 seconds , after that i tried to downgrade to 1.1.4 to no avail , lastly i restored back to factory settings just for it to go thru the process of restore and i tunes still not connecting > so basically im stuck on the screen with an usb pointing to itunes (which i cannot connet to ) Also when i put my sim card in it still says tmobile and I still get my texts.....im so confused!

    im using:
    1rst gen 8gb iphone
    unlocked to tmoible
    using 2.0.2 software
    windows vista

    Please help!
    2008-09-17 05:21 AM