1. coops03's Avatar
    Hi guys...

    I need some friendly advice/help regarding this message i keep getting when trying to browse safari on my iPhone:

    "Safari can't open the page because it can't find the server."


    Now i've researched it up all over google - and there just seems to be no solution that is appearing to work for me.... - The details:

    I'm wanting to connect to my locked home wireless network which uses a WEP key for security. Now the iPhone recognizes the signal, and i am able to input the key successfully and (supposedly) i'm connected to my home network. However, i then go and open safari - and it presents this message. Now in the seetings on my iPhone for my home network, In all 3 DHCP/BootP/Static sections, i have an IP Address and Subnet Mask - both of which were automatically put into the phone upon connection to the network. (Router, DNS and Search Domains all remain empty) My HTTP Proxy setting is on "Auto" for all three sections (as recommended/advised by other forums), and yet, i STILL cannot surf safari at home...

    It appears to work fine in other networks (mostly unprotected) - except my home! Can anyone help me out here...i would reallyreally appreciate it!

    Thanks guys!
    2007-12-26 06:37 PM
  2. bhz1's Avatar
    I found that my home secured wifi works best if my HTTP proxy is set to "off". You may also want to set your DNS to be the same as your Router address. That helps for some users. Alternatively, you can try one of the Open DNS server addresses: 208.67.222.222 or 208.67.220.220. Interestingly, I have had more trouble connecting to open public wifi if the signal is anything but strong. In that situation I can sometimes connect with an open DNS address and setting the HTTP proxy to auto. I find that the open DNS addresses help me connect to public wifi at times.
    2007-12-26 07:28 PM
  3. coops03's Avatar
    thanks for the response...
    ...I updated my DNS server to one of the open ones you provided, and unfortuantely both of them didn't work (I did this also with the HTTP proxy off)...
    I also just tried copying the IP and Router address' from those on my MacBook (whilst my MacBook being conected to the network) - and that also failed in providing a connection on safari, as it still came up with the same message!
    I'm not quite sure what else i need to do... - i'm really quite stuck and is a big bummer for me as this is half the reason i got it!!!!..solutions?!
    2007-12-26 07:39 PM
  4. peeInMyPantz's Avatar
    after connecting to your wifi,
    try reseting your DNS manually to 208.67.222.222
    then connect again.
    it works for me, i have no idea what this number is.. but i found this solution online, somewhere
    2007-12-27 10:20 AM
  5. needspermware's Avatar
    i reboot my wireless router, clear cache and cookies of safari. it works for me.
    2008-01-13 08:40 PM
  6. GenghisPhlip's Avatar
    Just restart everything (router, phone) and it should work fine. I know that is basic troubleshooting but it worked for me in the same situation.

    GenghisPhlip
    2008-01-29 04:40 AM
  7. hey-man's Avatar
    hey
    i'm having the sme problem
    i've tried all thing that you said before but still i can't conect to my wi-fi server
    2008-02-05 11:22 PM
  8. AKOMPLIS's Avatar
    I am experiencing the same thing after jailbreaking my iphone to 1.1.3 using ZIPHONE.

    Anyone find a solution to this issue? Ive tried all suggestion on this thread to no avail...
    Coops? Hey-man?

    Just add another note to my previous post, I tried my girlfriends iphone and it is experiencing the same problem and its firmware is 1.0.2. Strange.
    Last edited by AKOMPLIS; 2008-02-23 at 04:11 AM. Reason: Automerged Doublepost
    2008-02-23 04:11 AM
  9. hey-man's Avatar
    yeah i solved the problem

    be sure about the router or try in a different part


    or in a friend house
    2008-02-23 03:06 PM
  10. setesami's Avatar
    I'm having the same problem but i'm not even connected to wifi. It's giving me the error message when I try using 3g. It's not the area either becuase its happening at work where I use the phone all the time. I've tried to restart. cleared cookies, cache, and history. I dont know what other options there are. Any help would be appreciated.

    edit. it's a 3g iphone and im running the 2.2.1 firmware
    2009-02-27 11:15 PM
LINK TO POST COPIED TO CLIPBOARD