1. vietladin's Avatar
    That is what the iphone that i'm going to buy tonight says. It is unable to make call, or anything. The guy is selling it super cheap, and it's in mint condition. According to him, it has never been dropped, and no water damage. Just that screen. Now, I looked online, and a lot of people have been saying, that is something has corrupted the baseband, and it is fixable, without going to apple. Is this true? I was going try to put the phone in restore mode, then use iliberty, and upgrade the firmware to 1.1.4
    Then, attempt to jailbreak it. Has anyone had a iphone that had this screen? If so, how did you fix it? If anyone was going to suggest it, I can't take it back to apple, because, he doesn't have the receipt. Last note: phone was never unlocked, or jailbroken. (Until I get it fixed, that is )
    2008-07-12 02:02 AM
  2. Skyfinity's Avatar
    Hi Vietladin.
    The dude down at "The Daily Mac" has attempted to restore an iphone baseband to it's original form, and you probably should check out his results. It will be a tad difficult, but with the motivation of that you got it "super cheap" I think you'll be able to pull it off.

    Here's the link:How to Fix “Repair Needed” on the iPhone | The Daily Mac
    If you are successfull, please tell us, cause i'm sure there are people that have your same problem. Thanks!
    And you thought an iPod was for listening to music!

    It may have... until it met

    Skyfinity, T3h H4X0R
    2008-07-12 02:35 AM
  3. Kruejl's Avatar
    I had this happen on my current iPhone. It is possible to bring it back to life, but quite a long process. If I remember right, I used the old Ziphone (2.5) to virginize it, then downgraded to I think 1.1.3. Then used BootNeuter to fix the bootloader. And finally a fresh Restore and iLiberty+ to JB. I honestly don't remember all the steps, but after many hours I brought it back to life!
    Apples taste good.
    2008-07-12 02:41 AM
  4. cartman13's Avatar
    I have come across a phone like that and could not repair it. I tried every method short of opening it and connecting the test points. (I think the boot loader was corrupt). You can't flash the boot loader if it's corrupt without opening the device. All of the software methods get hung up when checking for boot loader version. I have no idea how to distinguish corrupt baseband from corrupt bootloader by looking at them.
    2008-08-07 06:52 AM
  5. Pcpro745's Avatar
    doesnt Kiphone work for that problem?
    2008-08-07 07:23 AM
  6. cartman13's Avatar
    doesnt Kiphone work for that problem?
    Thats what i've read. I've tried kiPhone, ziphone, iliberty, even running reflashes from w/in mobile terminal after loading files onto the phone.

    Nothing worked on the phone i as working on.

    My guess is that the person somehow badly corrupted the boot loader, or there was a hardware issue with the phone i was working on.
    2008-08-07 07:41 AM
  7. Pcpro745's Avatar
    Sounds like a call to apple?
    2008-08-07 08:29 PM
  8. Poseidon79's Avatar
    Use kiphone (the CORRECT version) to ierase the baseband and then restore to 1.1.4 and it should re-write your baseband.
    2008-08-07 08:39 PM
  9. Pcpro745's Avatar
    Thats what i said to use but ive never used it so it was just a suggestion
    2008-08-07 08:47 PM
LINK TO POST COPIED TO CLIPBOARD