1. philippe20's Avatar
    Hi all, I'm new into this forum and just recently bought a new iphone (unlocked). My wifi was running smoothly before with no problem, and suddenly a week ago, it still can be turned on (it's not greyed out), but iphone can't find my wireless modem at all. I tried it at my uni and it couldn't find any wireless network at all. The worst part is my iphone's battery run out so fast. It lasts at least 5 hours standby. I guess it's something to do with the wifi.

    I read in this forum, that some ppl suggest to update my firmware. But the thing most of the guide needs wifi to upload the file into iphone. I don't know as well what kind of method or program the seller used to unlock my iphone as it was already unlocked when i bought it. I was wondering if anyone has solved this issue before. Any help would be appreciated. Thank you
    2008-01-02 02:01 PM
  2. Eurisko's Avatar
    If WiFi can't find a signal, and its left on, it will run the battery down. But not as fast as leaving SSH on. Did you used to connect to your home's wireless router, have you made any changes to it recently?
    Get "iPod & iTunes for Dummies", it'll change your life.
    2008-01-02 02:34 PM
  3. philippe20's Avatar
    I still can turn off and turn on the wifi. The slide is not greyed out. But when I turn on, it just can't detect any wireless at all. But my battery runs out fast lately regardless the wifi turn on or turn off. Before, the battery has no problem (that is, the time when i still can detect wireless).

    Yeah I used to use it to connect to my wireless home. and I didn't make any changes at all. It just suddenly can't detect any wireless at all. I tried at uni (where i could detect wireless network before), and there was no wireless as well. I tried reset my network settings (as suggested by some ppl), but nothing happened. Do you know what I should do?
    Last edited by philippe20; 2008-01-03 at 01:29 AM.
    2008-01-03 01:25 AM
  4. cosmoLV's Avatar
    Settings/Wi-Fi then go to wi-fi network settings and see, maybe you accidently put some static IP address, switch to DHCP
    -
    Maybe this helps
    Country: Latvia
    Carrier: LV LMT
    Runing On FW: 2.0 BL 3.9
    -------------------------------------
    2008-01-03 01:31 AM
  5. MgNate's Avatar
    I would do as suggested above but also try to get stumbler and see if it detects a Wi-Fi network.
    2008-01-03 02:10 AM
  6. philippe20's Avatar
    I went to Settings/Wifi.. and there is not setting button there. there are only slides for turn on and off wifi and then the slide for Ask Join Networks. How do i get to the setting to set to DHCP? I'm on 1.0.2
    2008-01-03 04:18 AM
  7. Eurisko's Avatar
    You won't see anything under the WiFi settings, unless you're actually connected to a network. Have you checked the settings on your router? Is the wireless network set to Broadcast SSID? If not, your iPhone won't detect anything.
    Get "iPod & iTunes for Dummies", it'll change your life.
    2008-01-03 02:37 PM
  8. cosmoLV's Avatar
    I went to Settings/Wifi.. and there is not setting button there. there are only slides for turn on and off wifi and then the slide for Ask Join Networks. How do i get to the setting to set to DHCP? I'm on 1.0.2
    Ok, i made little tutorial for you
    Country: Latvia
    Carrier: LV LMT
    Runing On FW: 2.0 BL 3.9
    -------------------------------------
    2008-01-03 02:53 PM
  9. Eurisko's Avatar
    Ok, i made little tutorial for you
    That's nice. But unless there is a network to connect to, the only thing that shows up under the list is "other". Which asks you to manually configure a new network.
    Get "iPod & iTunes for Dummies", it'll change your life.
    2008-01-03 03:07 PM
  10. philippe20's Avatar
    Guys thanks for your help. But the problem I can't detect the wireless connection at all. Eurisko, I used to connect to my wireless at home with my iPhone before and I haven't changed any setting from my router since then. So, I guess it's not my wireless issue but it's something to do with my iphone? Since this problem occurs, my battery life is only 5 hours standby
    2008-01-07 01:08 AM
  11. macbeath's Avatar
    Hey, I have exactly the same problem that you have... been trying like crazy to find something about it... the last time I used the Wifi connection was on monday the 7th, I entered the Installer aplication and updated al my apps (which ware 3), after that.... DEAD...

    I remembre it updated Laberynth, and the 2 others I canīt remember...

    I have reset the network settings, and reseted the hole phone and NOTHING...

    I'm running 1.1.1

    Thnx guys for any aditional info....

    Was there an app that detected wifi hotspots or something like it???? see if it's software or hardware...

    PD. I dropped my phone in a big deep pool, but it came bach to life, everything is working fine, bluetooth, phpne, EDGE, iPod, and I updated the apps, so wifi WAS working... until the update...

    Be careful on what you update...
    2008-01-09 06:49 PM
  12. linglingchan's Avatar
    Hello all,

    I got this problem also, it it better in my iphone. I can connect to network if I leave my iphone for a few hours.

    Do you feel that the iphone is warmmer than normal at the location near the apple logo ?
    2008-01-17 09:01 AM
  13. astrozombie's Avatar
    i have the same problem if anyone has fixed this please let us know


    in other words...... BUMP
    2008-01-17 10:25 AM
  14. mdking's Avatar
    same problem. Had iphone 2g for 3 yrs without any problem. Inherit to daughter when getting new one. runing 3.1.3, jailbreak it, put the togo phone card. worked! now wifi is not stable. Sometimes has it, sometimes not. I was thinking to let her have togo phone because wifi can solve the communication problem. It was not true. Someone please help.
    2010-07-04 04:26 PM
LINK TO POST COPIED TO CLIPBOARD