1. Kuzzo's Avatar
    I've updated my 1st gen phone to 2.0 and unlocked etc using PWNAGE. All is fine, but when I connect to iTunes, an alert pops up

    [IMG]/Users/stephenk/Desktop/Picture 1.png[/IMG]

    'An update to the carrier settings for your iPhone is available. Would you like to download it now?

    Has anyone experienced this? Should I update? I'm cautious before doing this as it may have some negative effect to the current state of my phone.

    Any advice would be appreciated

    Cheers
    Last edited by Kuzzo; 2008-07-21 at 12:41 AM. Reason: image missing
    2008-07-21 12:38 AM
  2. nickh's Avatar
    Hi mate,

    I did updated carrier settings after 2.0 upgrade. Was a bit should I shouldn't I, but took the plunge. All was AOK! What it did for me (optus) was put some settings numbers mainly and a few web links in Setting>Phone>Optus Services.

    Nick
    2008-07-21 01:24 AM
  3. Kuzzo's Avatar
    Thnx Nick, I'm with Optus as well. The update did just what you said it would.

    cheers
    Stephen
    2008-07-21 01:04 PM
  4. nickh's Avatar
    Pleasure.
    2008-07-21 01:09 PM
  5. sura's Avatar
    1 Gen phone on 2.0 using T-Mobile USA with T Zones internet.

    If you're not on an official carrier, can Apple's carrier settings be good for you?
    2008-07-21 03:08 PM
  6. enrigonz's Avatar
    1 Gen phone on 2.0 using T-Mobile USA with T Zones internet.

    If you're not on an official carrier, can Apple's carrier settings be good for you?
    I have the same situation. Can I do this setting update without it affecting or bricking my phone?
    2008-07-21 03:54 PM
  7. noelleon's Avatar
    I get the same message but when I try to update I get this :
    iTunes could not check for an update to the carrier settings for your iPhone. An unknown error occurred (1630).

    I am with norwegian Telenor / Talkmore.
    Last edited by noelleon; 2008-07-21 at 05:16 PM.
    2008-07-21 05:09 PM
  8. adeepak's Avatar
    Went ahead with update on 1st gen unlocked iPhone on Vodafone India. Completed successfully. Not sure though what it updated. I guess it just updated the default regional Format in General -> International. Couldn't see any other changes.
    2008-08-31 12:28 AM
  9. mkq786's Avatar
    Hi,

    I am using Three network from Hong Kong. Although Three is the official carrier but i am using first gen phone on 2.0.1. After reading this thread, updated and seems all ok with apparently no prob.

    Thanks to all.

    Best regards.

    2008-09-17 05:29 AM
LINK TO POST COPIED TO CLIPBOARD