1. BlueBliss's Avatar
    I'm only a few days away from some important meetings and would appreciate some help.

    This morning, Cydia stopped working on my first-generation iPhone and would not open the program. It would start up, remain white, and then exit (similar to Customize problems pre-2.0)

    I reset my phone and went to eat dinner, but when I got back, the phone was off. To my surprise, I turned it on and the phone was stuck in recovery mode (It shows a penguin and a iphonelinux.org website, which I'm guessing is the WinPWN replacement for recovery mode graphics.)

    Anyway, I have nothing against restoring my phone with the hacked 2.0 firmware I have, but I desperately need my SMS messages and notepad files as they contain company data that I will be needing soon.

    If anyone can help me even *temporarily* access these files or somehow back them up, I would be grateful.

    I have a PC, first-generation iPhone and has been WINPWNed.


    Thanks
    2008-08-06 04:39 PM
  2. dirtybird1977's Avatar
    After you restore and pwn it again when iTunes asks if you want to set up as a new phone or restore from backup choose restore from backup. It should have all your sms as long as you have synced with iTunes lately.
    Dirty as I wanna be!
    2008-08-06 04:51 PM
  3. BlueBliss's Avatar
    Thank you for the prompt response DirtyBird, however I have not synced my phone for over two weeks, and some of that information I need has been inputted this past week.

    I've tried to use iTunes' in-store activation module trick but it won't work. Nothing in iTunes changes for me, so I'm downloading an actual in-store copy of iTunes via torrent.

    iBrickr obviously won't recognize my phone (since it is 2.0) either.


    Any help, again, would be much appreciated.
    2008-08-06 05:49 PM
  4. dirtybird1977's Avatar
    Can you SSH into your phone still. If you can, you can save a copy of your sms archive located at private>var>mobile>library>sms

    Then pwn your phone again and SSH back in and load that file back in the same place.
    Dirty as I wanna be!
    2008-08-06 06:06 PM
  5. BlueBliss's Avatar
    Alright, this sounds like something I can definitely do since I've SSH'ed many times pre-2.0.

    Bear with me, though. I've tried various different ways to SSH into the phone but cannot. This is BEFORE the phone went into restore mode, though.

    I tried the SSH kit and WINSCP but it won't let me log in and gives me a timeout error. I also tried iPhonebrowser 1.52 and it will let me do everything EXCEPT click on the main folders such as Var, etc. It will always give me an error when I do this.

    Any real way to SSH into my 2.0 phone?
    2008-08-06 06:18 PM
  6. dirtybird1977's Avatar
    Do you remember if you installed OpenSSH via Cydia before it went wonky on you?

    Have you tried doing a hard reboot? Hold the home and sleep/wake button untill the screen goes black and then let go of both buttons. Let it sit for a little bit then turn it back on.
    Dirty as I wanna be!
    2008-08-06 06:34 PM
  7. BlueBliss's Avatar
    Yes, I had installed openSSH and a variety of other SSH-like programs, but none worked. I even installed Terminal.

    Btw- As far as the iPhoneBrowser program goes, it won't recognize the iPhone.

    Also, yes, I have tried to reboot the phone by holding power and home. Nothing happens. Always goes back to the penguin on the screen (which I'm sure is recovery mode as iTunes states.)
    2008-08-06 06:42 PM
  8. kurrupt_1's Avatar
    Unfortunately I feel a disappointment is in store.
    If you can't do it on one wheel, try harder!
    2008-08-06 06:47 PM
  9. dirtybird1977's Avatar
    Yeah, I'm not sure you are going to be able to save those messages. Because it is in recovery nothing is going to want to connect to it. I don't know of any program that will allow you in the system while in recovery. Here is something I found. http://www.modmyi.com/forums/file-mo...-recovery.html
    It deals with recovering pictures but it should work the same to recover sms
    Dirty as I wanna be!
    2008-08-06 06:58 PM
  10. weezyhuy's Avatar
    See if you can take it out of restore mode, I think it's in restore mode because you may have accidently place it in restore or DFU mode when you tried to restart the phone.

    Sorry if it's out of topic, an iPhone is no place for sensitive information such as business files. Especially, if it's jailbroken and your experimenting with different applications. I do not mean the dev's jailbreak solution is unsafe. A jailbroken iPhone, especially with firmware 2.0, should only be used for educational purposes and experimenting with new applications.

    It's just that your business should be be based on a structured backbone rather than depend on a developing structure. I store business files are on my Blackberry which is also backup and synchronized on two NAS drives. I would not dare to store anything on my jailbroken iPhone, judging from the number of apps I purchase or download.
    2008-08-06 07:07 PM
LINK TO POST COPIED TO CLIPBOARD