1. okitsugu's Avatar
    I just decided to drain my battery till it went completely off. Its now been an hour since it shutted off ( i plugged it in for a charge right after) and its still doing its precharge.. anyone else getting that? i knew it took awhile on the old iphone as well but this is a bit extreme.
    2008-08-07 07:04 AM
  2. Zeal's Avatar
    Give it time.
    Rome wasn't built in 1 day
    Sure was destroyed in one tho.
    EDM
    2008-08-07 07:25 AM
  3. cartman13's Avatar
    turn it on. it'll probalby correct. read someone else was having the same issue. people suggested rebooting and one restoring. don't know if that fixed anything.
    2008-08-07 07:38 AM
  4. Kaloyan's Avatar
    Isn't this supposed to be in another section like General iPhone Chat? Just saying. And like Zeal said just give it time should charge eventually.
    2008-08-07 08:00 AM
  5. Aiyo's Avatar
    Isn't this supposed to be in another section like General iPhone Chat? Just saying. And like Zeal said just give it time should charge eventually.
    yeah..people dont know how to read these days.

    If I ever helped you or made a comment you like, press the "thanks" button!
    320GB HD 4GB RAM 2.2GHz Macbook
    500GB HD 4GB RAM 2.6GHz Macbook Pro
    2008-08-07 11:09 AM
  6. PhoneLine's Avatar
    Did you plug it in via AC power or the USB? Sometimes when a components power gets too low, the USB does not offer enough power to charge it, and it needs to be plugged into a regular outlet.
    2008-08-07 12:41 PM
LINK TO POST COPIED TO CLIPBOARD