1. iphoneboogy23's Avatar
    Hey all, didn't know where else to turn, so I thought I'd post my problem here and hope for some help.

    I bought an iPhone off craigslist and it is stuck on the iTunes logo with usb cable screen. I try to restore it with firmware 1.1.4 but iTunes always hangs on "waiting for iphone" with the iphone showing the apple logo and spinning dial. It does this even in DFU mode. I have tried all the different firmware versions, 1.0.0-1.1.1 all give an error when i try to load them (think it's error (3), and same with 2.0.2.

    I tried to boot it into normal mode with ibrickr, but the screen just turns green like I need to restore it. I also tried to boot it into normal using Ziphone, but it takes forever and after like an hour or so says "done!" but the iphone still shows the itunes logo. I also tried to use iLiberty and boot into normal mode, but it seems to nothing, even after a long time.

    I'm at a loss as to what to do, any hints would be greatly appriciated.

    If it matters I've tried most of these things on 3 computers, 2 running vista (one x86 and one x64) and also on XP. Thanks in advance!
    2008-09-01 08:56 PM
  2. satch2501's Avatar
    Make sure you are running an older version of itunes. Ify you have the latest version, then use winpwn and upgrade to 2.0.2. Look around on these forums for the steps.
    2008-09-02 03:39 AM
  3. iphoneboogy23's Avatar
    I have tried with iTunes 7.4.2, 7.5 and 7.7, all do the same things.

    Edit: when I try to load firmware 2.0.2 into winpwn it says unknown file, what am I doing wrong?

    Double Edit: I downloaded winpwn 2.5 beta and went thru all the steps for firmware 2.0.2, it still hung up on "waiting for iphone"

    Anyone got a solution?

    Anyone got a solution?
    Last edited by iphoneboogy23; 2008-09-02 at 08:03 PM. Reason: Automerged Doublepost
    2008-09-02 08:03 PM
  4. SundayDuffer's Avatar
    Ok..let go with the manual way....
    Press sleep button and home button til the itunes logo ubs image disappears..let go of the sleep button...and keep on holding the home button til itunes recognize it....restore to 1.1.4 factory firmware first. Try that first and let us know how it went.
    2008-09-02 08:34 PM
  5. jtesnani's Avatar
    are you putting the phone into DFU mode? if it enter DFU properly itunes should detect it
    2008-09-02 08:35 PM
  6. iphoneboogy23's Avatar
    I just did a clean install of iTunes 7.7

    I connect the phone, put it in DFU mode (screen stays black as iTunes recognizes it), and shift click restore and select the 1.1.4 firmware. Itunes gets as far as "preparing iphone for restore" and just sits there a while then gives me a 1601 error.

    Also: I ran the itunes diagonistic, didnt seem to see the iphone connected after it errored out, here's the log.

    Microsoft Windows Vista x64 Professional (Build 6000)
    Unknow Unknow
    QuickTime 7.5
    CD Driver
    CD Driver DLL
    Apple Mobile Device
    Bonjour (118.4)

    iTunes Serial Number 0205EC95786315FD

    Current user is not an administrator.
    The current local date and time is 2008-09-02 13:43:33.
    iTunes is not running in safe mode.

    Video Display Information

    NVIDIA, NVIDIA GeForce 8800 GT

    **** External Plug-ins Information ****

    No external plug-ins installed.

    **** iPod/iPhone Connectivity Tests ****

    iPodService is currently running.
    iTunesHelper is currently not running.
    Apple Mobile Device service is currently running.

    Universal Serial Bus Controllers:

    NEC PCI to USB Open Host Controller. Device is working properly.
    Standard Enhanced PCI to USB Host Controller. Device is working properly.
    Standard OpenHCD USB Host Controller. Device is working properly.
    Standard Enhanced PCI to USB Host Controller. Device is working properly.

    No FireWire (IEEE 1394) Host Controller found.

    **** iPhone/iPod Touch Sync Tests ****

    No iPhone or iPod found.

    Alright, I tried DFU mode with firmware 2.0.2, here's what happened. The screen stayed black up to when it said "preparing iphone for restore" then it flashed white, then showed the silver apple logo. After a few seconds the spinning dial appeared and itunes said "waiting for iphone" where it is now stuck, and will probably be until I disconnect the iphone.
    Last edited by iphoneboogy23; 2008-09-02 at 08:53 PM. Reason: Automerged Doublepost
    2008-09-02 08:53 PM
  7. SundayDuffer's Avatar
    Try to get the older version of iTunes...v7.5 or so...
    2008-09-02 09:21 PM
  8. iphoneboogy23's Avatar
    As I said in an earlier post, I have tried iTunes 7.4.2, 7.5 as well as the latest version. All get stuck "waiting for iphone"

    Also I just tried on a mac with firmware 2.0.2, also got stuck in the same place.
    Last edited by iphoneboogy23; 2008-09-02 at 11:04 PM.
    2008-09-02 11:02 PM
  9. SundayDuffer's Avatar
    Let try this all over again.

    Uninstall iTunes....trash everything...including the execution file.
    Go to itunes..download a fresh version and install that.
    Plug in your phone in DFU mode...and restore 2.0.2 to factory settings..itunes will download the firmware itself (this takes awhile).
    After youre done with that, use winpwn 2.5 and the new firmware to make your custom fw.
    Then restore the phone again using the custom fw.

    I know it's a long process...but keep on trying. I did this two days ago helping a friend...took me all day, all kinds of errors i got....finally, i did it.

    2008-09-02 11:32 PM
  10. iphoneboogy23's Avatar
    I will try this, but I can almost gaurantee the phone will get stuck at the "waiting for iphone" stage, i think when its trying to reboot or something.
    2008-09-02 11:35 PM
  11. SundayDuffer's Avatar
    I will try this, but I can almost gaurantee the phone will get stuck at the "waiting for iphone" stage, i think when its trying to reboot or something.
    you'll be fine. Dont give up.
    2008-09-02 11:40 PM
  12. iphoneboogy23's Avatar
    As I suspected, even after uninstalling everything iphone related and reinstalling a brand new iTunes, it hung at "waiting for iphone" in both recovery and DFU mode.
    2008-09-03 12:10 AM
  13. Atreides's Avatar
    Well, either (a) you've not tried everything - so don't give up, or (b) the phone is a dud, perhaps the prior owner experimented on it - opened it , yada yada... In any case, just throwing out some more food for thought. I queued into your 1601 error, which I recall from a long time back.

    Another thread on this site which might be useful:

    Apple suggestions for a "clean" itunes install (if above is a deadend):
    Error 1601 or 1602 when restoring iPhone or iPod touch in iTunes

    Good luck!
    2008-09-03 02:14 AM
  14. Denni's Avatar
    I've got the same problem. I've tried everything(xp, vista), but it's always stuck at "waiting for iPhone".
    I have got exactly the same problem(get the same responses etc. if I try this stuff). Do you already have a solution?
    2008-09-22 05:15 PM
  15. iphoneboogy23's Avatar
    Nope, still haven't found a solution.
    2008-10-13 12:46 AM
  16. Denni's Avatar
    Well for a small part, my problem is solved. But the problem is still there, and very irritating.
    After having tried around 40-50 times(yeah really boring) to restore in DFU, I managed to restore it. But after that, it jumped into recovery mode again(because I touched the screen?><), but I managed to restore it faster again, and now I've restored it already several times, after it jumped into recovery mode. But I can't work with it properly because after a restore, mostly at least 1 of the apps is defect and makes it jump into recovery again(or if i listen more that 2 minutes music or so). Really irritating and frustrating I thought that my problem was solved but it isn't any better, still can't use my phone. But gonna keep trying!
    2008-10-13 12:53 AM
  17. one1's Avatar
    Flex Cable failure. The Flex Cable controls the data that passes through the port on bottom of the iphone. On that connector are several pins, some are input, some are output. On the inside of the flex cable behind that port are a series of micro surface mount resistors, which go into more down the line. If one fails you will not be able to sync.

    You can see them on the connector in this post: http://www.modmyi.com/forums/general...-i-y-pics.html

    For MOST of you it is just going to be stupid mistakes like not in DFU mode or having to use a different USB port. For the one's that have done everything possible and still can't restore...... you have a bad flex cable.

    For the guy that got it to restore and then touched the screen and it kicked back into restore mode........ you have a hardware failure. (the Flex Cable)

    You can use the tutorial I gave to try and make your phone work, or you can hand it over to me: http://www.modmyi.com/forums/iphone-...uff-money.html

    DO NOT contact me until you have tried EVERYTHING listed up there to make it restore. If it still won't do it after the checklist, you are not getting information to the phone and that's when it is time to replace the flex cable. GOOD LUCK! (you'll need it)
    2008-10-13 03:03 AM
  18. Denni's Avatar
    @one1, well it jumped just automatically in restore mode the first time as i touched it. At the moment it's in restore-mode-only-mode again, so I am trying to get it restored again. But every time I try to work with it probably it jumps into restore mode again, so I guess you are right that it's an hardware failure.
    I don't have any experience doing this stuff, but I live in the netherlands, so I don't know were you live, to repair it?
    2008-10-13 09:46 AM
  19. one1's Avatar
    I'm in the states. No problems with helping if you don't get it worked out. Good luck on it!
    2008-10-13 07:46 PM
  20. Denni's Avatar
    Hmm ok, thanks but are you sure it's the flex cable? Bit stupid to risk the phone when im not sure it's really the flex cable
    2008-10-21 05:23 PM
22 12