1. Edrill's Avatar
    Hey guys. New here, but the problem is old!

    I have an iPhone that was 1.0.2 OTB. Wifi hasn't worked on it at all. Upgraded to 1.1.3 in the hope that it would fix my problems, but no go. A guy on another forum told me that I'd need to go back to 1.0.2, downgrade my baseband and virginize my phone and see how that goes!! Tried that, but kept having problems with iBrickr talking to the phone. Kept saying that it had to be downgraded to 1.0.2 even though it already was 1.0.2. Got fed up and am currently using it at 1.1.3 with everything except wifi functional.
    One thing to note is that when I was on 1.0.2, I used to get the option to turn wifi off and on, but it would never see any networks. After upgrading to 1.1.3 it always shows No Wifi. Now it even shows No Wifi when I downgrade back to 1.0.2. I know that I'll have to go back to 1.0.2, use iBrickr or some equivalent software to get BSD and SSH installed so that I can downgrade the baseband and virginize it. Just wanted to know if anyone has any other suggestions or tips before I go ahead and downgrade again. Any help is greatly appreciated!
    2008-02-19 06:08 AM
  2. Edrill's Avatar
    Nothing???

    I downloaded iDemocracy 2.0.3 and noticed that it has options to downgrade the baseband and virginize the phone. Anyone try this out yet?? Would it be worth giving a shot after downgrading to 1.0.2???
    2008-02-21 04:58 AM
  3. Edrill's Avatar
    Well, finally managed to downgrade the firmware to 1.0.2, baseband to 3.14.08 and also revirginized it, but still no wifi! Tried the entire downgrading/virginizing process twice with no wifi, so I'm back to 1.1.3 Everything except wifi working. Looks like it might be a hardware issue after all. Not that it's likely to help, but I guess I'll probably upgrade to 1.1.4 when an unlock is out for it.
    2008-02-27 08:27 PM
LINK TO POST COPIED TO CLIPBOARD