User Tag List

  1. Alexsander's Avatar
    Hi guy,

    I tried to upgrade my Iphone from firmware 1.1.4 to 2.0.1 last night. It locked up and gave me a 1604 error. I have tried to restore it many times on 3 different computers (an XP machine, a Vista machine and a Macbook) and keep getting the same 1604 error. My IPhone looks like it is restoring properly but then I get the error and the screen is locked showing the white apple and there is no moving circle . I try put my IPhone into DFU mode by first holding the power button and the home button until the screen goes blank. I then hold the home button until Itunes recognizes the IPhone. Itunes gives me the message that it has detected the IPhone in Recovery Mode and prompts me to restore it. I keep trying to restore to 2.0.1 By hitting the shift button and selecting the 2.0.1 firmware. In either case, I get the 1604 error. Even withe trying 2.0.2 firmware.

    I have uninstalled Itunes, Apple Mobile Device, Quick Time and Apple Software Update programs and reinstalled but still get the 1604. I tried this on the Vista machine and the XP machine.

    Any suggestions would be greatly appreciated. Coz I'm losing my grip

    Please Help me,,,,,,
    2008-09-03 04:20 AM
  2. Grassmasta's Avatar
    1)downgrade to iTunes 7.5

    2) install non-custom 1.1.4 firmware.

    3) upgrade to 2.0 (you might need to upgrade iTunes for this)

    4) upgrade to whatever custom firmware you like.
    2008-09-03 04:45 AM
  3. SundayDuffer's Avatar
    try that again..DFU mode...different usb port...just click restore itself...dont shift click restore...see if that will work.
    2008-09-03 04:47 AM
  4. satch2501's Avatar
    Make sure that you have the "device support" folder in your user/library/itunes folder (obviously on mac). If its there and there is the following file in it : x12220000_4_Recovery.ipsw, then remove it and pwn your device with the latest pwnage tool which can be found here: http://blog.iphone.org
    2008-09-03 11:55 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD