1. Napoleon_PhoneApart's Avatar
    I had the same problem with that router last night at a friends. You have to select the WPA password authentication setup.
    I did that before I read your reply, and all seems to working well now.
    2007-07-06 02:51 AM
  2. shagster40's Avatar
    why does my iphone what to connect to edge all the time. I want to use my wifi insted. Any way to make this happen?
    2007-07-06 04:40 AM
  3. Kyle Matthews's Avatar
    It should connect to your WiFi anytime its present. If not, just go to Settings and change to the WiFi network.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-07-06 05:10 AM
  4. shagster40's Avatar
    I have great signal under wifi settings but while on the net or checking mail the only icon I ever see up top is the E.
    2007-07-06 10:19 AM
  5. JedixJarf's Avatar
    Had that problem too. Set router encryption to WPA.
    2007-07-06 04:35 PM
  6. Napoleon_PhoneApart's Avatar
    JedixJarf is right. As soon as I set my router encryption to WPA instead of WEP, my iPhone was able to see the network just fine.
    2007-07-06 05:02 PM
  7. shagster40's Avatar
    ok I set my router to EPA but still only connecting to edge. Under wifi settings I even have a check mark and everything.
    2007-07-07 07:34 PM
  8. JedixJarf's Avatar
    What kind of router are you using?
    2007-07-07 07:41 PM
  9. shagster40's Avatar
    its a netgear a b g wgu624

    ok after messing around for a good 30 Min. My router is set to wep / shared key and I connected using other networks and boom I am posting right now on my wifi. Thanks for all the help guys.
    Last edited by shagster40; 2007-07-08 at 07:00 AM. Reason: Automerged Doublepost
    2007-07-07 11:28 PM
  10. Kyle Matthews's Avatar
    Glad to see you got it working!
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-07-08 07:12 AM
  11. iphonejeff's Avatar
    I why does my wifi keep on disconnecting From my iPhone...
    2007-07-09 07:18 PM
  12. JedixJarf's Avatar
    Be more specific.
    Give us details.
    2007-07-09 07:19 PM
  13. iphonejeff's Avatar
    well I go to connect my iphone to my router and it connects but alil while i go check and it and it says not connected..
    2007-07-09 07:38 PM
  14. JedixJarf's Avatar
    what kind of security authentication are you running on your router?
    2007-07-09 08:11 PM
  15. iphonejeff's Avatar
    i got wap-psk

    i mean wpa-psk
    Last edited by iphonejeff; 2007-07-09 at 08:53 PM. Reason: Automerged Doublepost
    2007-07-09 08:52 PM
  16. JedixJarf's Avatar
    okay if you are going to use wpa then you need to use wpa2-psk [aes]. And that should get you up and running.
    2007-07-09 09:56 PM
  17. iphonejeff's Avatar
    ok thanks I'll go fix it right now!!
    2007-07-09 10:33 PM
  18. JedixJarf's Avatar
    Cool let us know how it goes for future reference.
    2007-07-10 12:55 AM
  19. SpeedSwede's Avatar
    I just got an iphone today and was trying to get it to work on my home wifi network. My network uses MAC filtering and also WPA-PSK encryption. After some serious effort, I figured out that it must be the WPA-PSK setting that is causing the problem because if I turn it off completely and still leave the MAC filtering on, my iphone connects to my network. However, if I try WPA-PSK encryption my iphone asks for my password but still wont connect. I've made sure my automatic capital option is off. I've modified the wifi setting on iphone to try it as wpa and also wpa2. I assumed that wpa2 is the same as wpa-psk. Either way since I tried both one of them should have worked. I also called apple support but they couldn't figure it out. Anyone want to take a crack at this. Note that my wireless router is a D-Link model #DI-624.
    2007-07-12 03:14 AM
  20. smlaux's Avatar
    I just got an iphone today and was trying to get it to work on my home wifi network. My network uses MAC filtering and also WPA-PSK encryption. After some serious effort, I figured out that it must be the WPA-PSK setting that is causing the problem because if I turn it off completely and still leave the MAC filtering on, my iphone connects to my network. However, if I try WPA-PSK encryption my iphone asks for my password but still wont connect. I've made sure my automatic capital option is off. I've modified the wifi setting on iphone to try it as wpa and also wpa2. I assumed that wpa2 is the same as wpa-psk. Either way since I tried both one of them should have worked. I also called apple support but they couldn't figure it out. Anyone want to take a crack at this. Note that my wireless router is a D-Link model #DI-624.
    I had a similar problem; had the settings set to enter the password as a password, but would never connect, but once I changed the setting to "ascii" mode and entered the password normally, I connected to my home wifi without any problems.
    2007-07-12 03:23 AM
41 123
LINK TO POST COPIED TO CLIPBOARD