1. Sseadoubleyou's Avatar
    I'm running a 1st gen 16GB model...

    #1. When I turn SMS message preview off, the message is still previewed regardless of the setting (on or off) it still displays when a text arrives to my phone. For some reason when you go into the setting you have to set a password to even get into it, I find this really odd.

    #2. Show my caller ID, the option is greyed out and won't let me change it (it's greyed out in the "OFF" selection).

    Any ideas on how to fix this? I'm running 2.1 (unlocked but not yet jailbroken).

    Well according to many others everyone is having the same problem with the sms message preview feature. It shows the preview whether you turn it on or off...obviously a bug.

    As far as the "show my caller id" not working (being greyed out and not letting me turn it on or off) I just fixed that. Found out from another website if you turn on airplane mode, then you can turn on "show my caller ID", then go back and turn off airplane mode and you are all set from then...you can now turn it on or off as much as you want. I guess that was a unlock glitch?

    Hope the info helps anyone else who runs into the problem.
    Last edited by Sseadoubleyou; 2008-09-17 at 03:52 AM. Reason: Automerged Doublepost
    2008-09-17 03:52 AM
LINK TO POST COPIED TO CLIPBOARD