1. Nitwit's Avatar
    I upgraded my first gen iphone from the jb 2.0.2 firmware to the new 2.1 firmware, which I planned to jailbreak. Well, I am guessing that not uninstalling a few jb apps may have done a number on the phone. I updated to the new firmware and most of the apps I had in folders in categories are now completely hidden. iTunes says they are on the phone, but I am not seeing them. The app store and itunes icons are there, but everything else that were placed in folders from the program categories, are hidden. Even Cydia and installer were hidden after jailbreaking 2.1. They too were in folders created by the Categories program. Even my Settings icon is hidden.

    I have already gone ahead and did a recovery and reinstalled the 2.1 software, but nothing else has shown back up.

    Anyone have an idea on what I have to do to get these things back, or am I hosed?
    Last edited by Nitwit; 2008-09-21 at 10:13 PM.
    2008-09-21 09:46 PM
  2. robhard24's Avatar
    I had the same problem when i upgraded it to 2.1.. After some time trying everything i could think of i figured it out... and just to let you know its a very simple fix.

    with a jailbroken phone, make sure you have boss prefs installed..

    start up boss prefs, choose the poof icon (it will then say enumerating apps)
    after some time you should have a list of all the programs that are installed in your phone..

    ON = programs/apps will show up

    OFF = programs/apps will be hidden
    2008-09-22 05:36 AM
  3. Nitwit's Avatar
    Unfortunately, I don't think that will work in my case. Cydia and Installer are both hidden too. Most of my apps are completely hidden. Even my settings. So installing other apps might be harder. If there is a way around not being able to see the Installers, let me know. Thanks!
    2008-09-22 12:51 PM
  4. iBlade's Avatar
    Hi Nitwit try this method, it worked for me.
    iPhone4World Blog Archive Jailbreak 2.1 (2g and 3g)
    Last edited by iBlade; 2008-09-22 at 04:02 PM. Reason: Automerged Doublepost
    Don't be shy if I helped you use the Thanks button, I do it.
    2008-09-22 04:01 PM
  5. grc's Avatar
    thought I was the only one in this mess, although relieved that it's happened to someone else and it's not a big dumb mistake I did alone, I am very sympathetic... Cuz this blows!!! My patience is at it's max cap after the last 2 iPhones (2g,3g) and 5 updates, jailbreaks later. Needless to say I'm pissed. I quickpwn to 2.1. Lost my categories "poofed" apps which include cydia, preferences etc, panic'd, tried to go back to my winpwn custom via shift restore. Now I'm back to the 2.0.2 minus the perfectly jailbroken and completely satisfied level of customization I had, not to mention all my appstore apps, cydia etc poofed somewhere in my phone. Damn curiousity for 2.1's bug fixes got the best of me. I going to wait for winpwn 3 before attempting any thing else
    2008-09-22 04:31 PM
  6. Nitwit's Avatar
    Hi Nitwit try this method, it worked for me.
    iPhone4World Blog Archive Jailbreak 2.1 (2g and 3g)
    I sort of tried this method. I just didn't uninstall itunes and the other program. I didn't know if I was going to lose all the apps I had downloaded that are not available in the store anymore. I tried all these steps without the old itunes and uninstalling that other program and still no cydia or installer on my desktop.

    Ugh. I guess I am not alone on this, but man, this sucks. I'd rather not have to go out and buy a 3g phone. Up until this big goof up, it has been perfectly fine.
    2008-09-23 03:51 AM
  7. m0nkay's Avatar
    samething happend to my phone. i upgraded to the 2.1 update and when itunes installed all my applications they were all missing from the springboard but all the settings were showing up under the settings menu. if i went to the apple store and showed them my phone would it be possible to get a replacement??
    2008-09-23 03:58 AM
  8. Nitwit's Avatar
    Anyone else encounter this or have a work around? This is a real killer to have no real access to things on the phone. I can't even get my Bluetooth activated anymore due to things being hidden.
    2008-09-25 03:43 AM
  9. ekidd's Avatar
    Did you happen to backup you phone from your existing info on itunes? If you did, thats probably the problem. You should set it up as a new phone if you didnt.
    2008-09-25 12:35 PM
  10. jasdxb's Avatar
    I found a solution:

    1.Enable Restrictions by going to Settings -> General -> Restrictions and key in a pass code
    2.Go to home and disable the restrictions (by going through the same menu above)
    2009-04-12 10:02 AM
LINK TO POST COPIED TO CLIPBOARD