1. ZeroShift's Avatar
    Just the other day, I upgraded my iPhone (2G, locked and Officially activate) from 2.1 to 2.2. I promptly Jailbroke it with absolutely no issues, and it worked fine until today. Now my Home Button refuses to work at all, except for when I use it and the sleep button to reset my iPhone. If it works for resetting and nothing else, you guys think this might be a software issue, and not hardware? Any advice?

    Thanks in advance,
    ZeroShift
    2008-11-24 11:30 PM
  2. one1's Avatar
    how could it be a hardware issue if it works........
    2008-11-24 11:32 PM
  3. cricketlang's Avatar
    i had the exact same issue only mine happened when i installed that app in cydia that allowed you to change your boot logo without rejailbreaking. i ended up uninstalling it and it worked just fine. as far as on your issue im not sure. if this didnt happen after a particular app install or mod....i would suggest doing a full restore and rejailbreaking while the jailbreak is still fresh
    The beatings will continue until morale improves.
    2008-11-24 11:33 PM
  4. ZeroShift's Avatar
    Come to think of it, it started acting up about an hour after installing AppBackup from Cydia. But there was a plethora of components it installed along side it..I'm performing a restore at the moment to see if it fixes the issue. I'll keep you guy posted, in the meantime I've got time to kill waiting for the 20 min restore process to complete xD

    Double Post: Sorry, just need it bumped.

    I restored my iPhone, with zero result. It appears it's a hardware problem, as every once in a while the home button will trigger randomly during phone calls >_> The next step I need help with now is: Since my iPhone is Jailbroken (actually, was) is it safe to send into Apple for repairs, or should I just attempt it myself?
    Last edited by ZeroShift; 2008-11-25 at 07:32 AM. Reason: Automerged Doublepost
    2008-11-25 07:32 AM
LINK TO POST COPIED TO CLIPBOARD