1. tonyb316's Avatar
    Hello. I have a problem where my iPhone 2G is not finding any WiFi network. The phone was recently upgraded to firmware version 2.2 using Pwnage tool where it was working without a problems but later on it began. Some calls were not being picked up also, since I had to see a bunch of missed calls. I restored with the custom 2.2 again, but no luck. This last restore I did in OSX 10.5.6, so I figured out that there was a problem there. Since then, I restored to firmware 2.1 in Windows and jailbroke with QuickPwn, but again, I have no WiFi. Any ideas on what could be the problem. It's not a router problem since I have another iPhone and other devices connected to it and they have no problems. I am currently restoring to 2.0.2 to see if it works. Any help is greatly appreciated.

    I was able to restore firmware 2.0.2 and at first it was not detecting WiFi again. I left it on all night long and I checked it today and it was seeing the networks. I was able to connect to my WiFi, but it disconnected shortly thereafter. So basically, the problem is that it is taking a long time to detect the network, but even when connected, it disconnects moments later. Before this I tried several times to "Reset Network Settings" but with the same result. I also tried "Erase All Content and Settings" which takes about an hour and a half and had the same result. Anybody with a similar experience or insight in what could be causing the erratic WiFi? I was thinking that it could be the WiFi driver in the phone, but I'm not sure which file it is. Thanks a lot.
    Last edited by tonyb316; 2008-12-17 at 03:47 PM.
    2008-12-17 01:09 AM
  2. tonyb316's Avatar
    Hey everybody. I finally got my iPhone to work properly, WiFi and cellphone. I did some digging on the internet an followed this guide by Poseidon79:


    Basically I erased the newest baseband (04.05.04) to an older one (from 1.1.4 firmware). It seems that when I restored to a custom 2.2 firmware, the baseband could have screwed up in the process. I got to the 04.04.05 baseband (from 1.1.4 firmware) and made sure that everything was working properly. Then I upgraded with iTunes to 2.2 then QuickPwned it. It seems to have worked. Anyways, I wanted to share this so that anyone that may encounter a similar problem can have this option. Thanks everybody and Poseidon79 for a great guide.
    2008-12-19 02:25 AM
  3. hellbone's Avatar
    Wow, my iPhone is resurrected! Thanks for this post!

    The wi-fi started acting up a while ago and eventually simply died. I thought it was a hardware problem until I came across this post. I followed the steps and now everything works perfect.

    The only little issue I came across, was as described here, by the very author of the downgrading guide: http://www.modmyi.com/forums/general...-firmware.html
    2009-04-24 06:19 AM
  4. mactommy's Avatar
    I tried this with no success. It all started when I installed 3.0 and unlocked it. Since then, I had issues with my wifi. When I went back to 2.2.1, Wi-Fi and bluetooth are greyed out. I guess I am stuck here as I am a T-Mo customer and bought my iPhone on craigslist. Any help is appreciated.

    2009-07-13 03:19 AM
  5. Titan3636's Avatar
    yeah i have a 2G on 3.0.1 and the wifi is in and out too. It will connect for a few secconds and then go back off again. I know that it was jailbroken & unlocked on 2.2 but then restores to 3.0.1 and hasnt been jailbroken or unlocked since then. Does anyone have a fix for this issue that will work on 3.0.1??????
    2009-08-26 03:30 PM
  6. Bridewell29's Avatar
    Well After Searching All Over The Internet I Finally Found The Solution. Unfortunately You'll Have To Restore Your iPhone To It's Factory Settings. You Do That By Turning The Phone Off, Then Hold Down The Power Button For 5 Sec, Then When It Comes On Hold Down Both Power And Home Buttons, The Phone Will Restart. Soon As It Restarts Let Go Of The Power Button And Continue Holding Down The Home Button For 20 Seconds Or Until The iPhone Reads Connect To iTunes. Finally Restore Your iPhone With What Ever Firmware You Were Using Before. Then Jailbreak. It's Something Inside Of The Firmware. If I Were You I'd Try Downloading A Fresh 3.0isp Firmware.

    I Just Did It And Im Almost 100% Sure This Will Fix Your Problem. Lots Of People Have Just Been Restoring Without Putting The iPhone Back To It's Store Bought Settings First. That Won't Work.

    If So Happen It Starts Acting Up Again, I'll Let You Guys Know. But As Of Now....
    It's All Good Baby!!

    I Hate To Say This....But I Have A Funny Feeling That Push Fix Might Be The Cause Of All This...Especially If You Have A 2G Like Me. I Just Have That Feeling. So Be Careful Of What You Guys Install On Your iPhones After You Restore. Try Monitoring Your iPhones Operation After Certian Installs. That Way Next Time It's Easier For All Of Us To Trouble Shoot.

    Word For The Wise

    Well Guys...About An Hour Or 2 After I Restored It, It Started Losing Wifi Again. It's Something In The Jailbreak. It Has to Be. Why Else Would It Pick up Wifi Flawlessly For 2 Hours Or More, Then All Of A Sudden Stop. I Think Apples In On This.

    So At This Point...I Don't Know.

    To Apple Care I Go!

    I Have Absolutely Positively Found What The Wifi Problem Is With The 2G iPhones. The Battery!. When The Battery Life Has Dropped. Wifi Will Not Work If Your Battery Life Is Higher? Than 50% I Thought This Was B.S. Until I Tried It. If You Have An Actual App That Allows You To See Your Battery Percentage, It's Been Proven. I Charged My Battery To Full Power Just To Put What I Found Out To Test. My Battery Was At 90%. My Wifi Went In An Out Constantly, Never Staying On More Than 10sec. The Second It Hit 50% Wifi Came Back Instantly, Never Disappearing Again.

    So What's Been Happening Is When You Restore It, It Resets Your iPhone Momentarily. But As Soon As That Extra Boost Of Battery Life Goes Away....Back To The Same Ole Wifiless iPhone.

    Basicly, Time To Get A New Battery Guys. They Run About $89.00 Either Shipping It To Apple Or Going To The Genius Bar. No Need To Buy A New iPhone. This Is The Real Problem.

    Hope I Help Eveyone Out There Looking For An Answer
    Last edited by Bridewell29; 2009-08-29 at 10:22 AM. Reason: Automerged Doublepost
    2009-08-29 10:22 AM
  7. Titan3636's Avatar
    did you get a new battey and it fixed the issue?? sounds kinda crazy to me. i have heard of features not working when battery life is sow to conserve energy but never when battery life is OVER 50%.
    Can anyone confirm that this is in face a solution?
    $90 for a new battery isint worth it. Ill just upgrade to a 8GB 3g referb for $50 in that case.
    2009-08-31 06:13 PM
  8. poopmastr7's Avatar
    just got an iphone 2G the other day. wifi wasnt working until last night when i was charging my iphone. it was almost completely out of battery, i had just left the wifi search on just to see if for some reason it would find something and after i was done watching some football i checked and it had found my wifi!

    it last the whole night connected. then this morning my phone was done charging, i try it again, and alas, no wifi connections today.

    what gives?!?!
    2009-09-14 08:40 PM
  9. jelassaad's Avatar
    I have been having this problem for a while and this is really frustrating me but i can assure you that i thought it could be from the battery when the level drops, but now it ia happening when it is fully charged. Then i thought it could be the firware, i downgraded many time but still and then upgraded still having the issue and now i am on 3.1 and still have the problem. At one point i thought this could be the phone what it gets warm, but i am having the issue even when the phone has been sitting idle for hours. So in conlusion, i am not sure anymore whether this is a hardware problem but the fact that many people are facing this issue makes me wonder whether it is a hardware issue or not.

    If someone finds the solution, please post it for the love of god
    2009-10-02 09:42 AM
  10. titeo's Avatar
    i am experiencing the same thing!
    1. horrible wifi connection. wifi dropping and not connected or unable to join a network
    2. warm iphone
    3. extreme battery drainage from just sitting idle with the screen off all day! WTF!?

    I am on 3.0.1, 2G unlocked and jailbroken. I've been experiencing all of this ever since upgrading from 2.1.1 to 3.0.1.

    I've been searching all around to find a solution for battery life, for wifi probs, and warm issues. And i've concluded, Apple is screwing us 1st gen owners to get us to buy the new iphone 3G or 3GS.
    1st Gen iPhone 2.0 - Jailbroken and Unlocked on T-Mobile
    2009-10-05 05:59 PM
  11. marianoux's Avatar
    Hello everyone,

    I have the same issue on my iphone 2g 3.1.2 firmware. I wanted to check if any of you have actually replaced the battery and had this issue fixed.. I have to change my battery anyway, because it hardly lasts more than half an hour of use (maybe 12 hours idle), but Im trying to decide wether to do that or save the money and buy a fresh bad*ss 3gs , someday.

    I look forward to hearing back from you, thanks!!!!
    2010-01-18 05:16 AM
  12. alg0's Avatar
    Verified, changing battery fixes this issue.
    2010-06-16 11:30 AM
  13. PrplHaz4's Avatar
    I've had this issue for quite a while now, and just got around to rectifying it today. After a failed attempt at downgrading to 1.1.4, I followed the instructions here:
    How to Jailbreak/Unlock 3.1.3 iPhone 2G Windows & OS X
    and continued to restore to 3.1.3, with Cydia, verbose boot and unlock (which was my real target, since I figured the previous unlock corrupted something important).

    Works so far, haven't run the battery down yet though...Will post up if the issue returns!
    2010-08-14 08:14 AM
  14. tunnnnnn's Avatar
    Please allow me to share my experience about (my) iphone 2g wifi problem.

    1. Problem occured after I've restored "3.1.2" original firmware and jailbreak/ activate/ unlock the phone with "Blackra1n"

    2. After that my iphone 2g can't not connect to any wifi networks at all.

    3. Then I did some google search. And found out that Baseband or BootLoader may have caused this wifi problem

    4. So, again, I Restored my iphone 2g to "3.1.3" firmware and this time I used "redsn0w 0.9.4" with the option "install cydia" AND "install BOOTLOADER 3.9 & 4.6" ..... ...

    5. Done!.. my iphone 2g wifi is back in order again...!!

    Good luck..
    ( google to find the BOOTLOADER 3.9 & 4.6 files )
    2010-09-28 03:24 PM
  15. viermele_rosu's Avatar
    Hello I have an Iphone 2g(3.1.3 jailbroken with redsn0w). I have a problem with wifi connection and the battery is draining fast. Wifi is connecting to router but after 10 sec. disconnects. I tried every solution:
    -downgrade to 1.1.4 and rewrite baseband
    -reset network settings
    -verified wifi cables.

    The phone connected one time to ad-hoc network hosted from my pc, but after did not connect to it anymore.

    But then I've installed Android and it works everytime.

    What should I do, I've ordered a battery from ebay, should it do the job?

    Thanks in advance.

    PS: Sorry for my bad english, I'm from Romania.
    2011-05-03 06:23 PM
  16. Mes's Avatar
    ... I've ordered a battery from ebay, should it do the job?...
    A new thread would make your question stand out better ... but to answer your question - maybe/likely . For sure the 2G battery is weak, especially if it has never been replaced before.
    2011-05-03 06:29 PM
  17. viermele_rosu's Avatar
    A new thread would make your question stand out better ... but to answer your question - maybe/likely . For sure the 2G battery is weak, especially if it has never been replaced before.
    I changed the battery, still the same problem.
    2011-05-15 12:25 PM
  18. Mes's Avatar
    Not good . I believe two choices remain. 1) Restore and hope it fixes it, or repair a probable hardware fault.

    If anything was installed before the problem first appeared, you can try removing that.
    2011-05-15 01:28 PM
  19. viermele_rosu's Avatar
    Not good . I believe two choices remain. 1) Restore and hope it fixes it, or repair a probable hardware fault.

    If anything was installed before the problem first appeared, you can try removing that.
    I will restore it. Should I try a baseband erase with KiPhone?
    But I don't understand why it works flawlessly on Android...
    2011-05-15 01:31 PM
  20. Mes's Avatar
    I will restore it. Should I try a baseband erase with KiPhone?...
    No. Use pwnagetool and the two bootloader files to create & load 3.1.3. You'll need to use an old pwnagetool for 3.1.3. Select options as if it was never jailbroken. The old guides at the top of the MMI web site (and iClarified.Com) are still valid.

    WiFi operation is a combination of hardware and software components. Failure of either will cause your problem.

    I am concerned your hardware is faulty. A restore will either fix it or confirm it's a hardware problem.

    Good luck.
    Last edited by Mes; 2011-05-16 at 04:53 AM.
    2011-05-16 04:43 AM
21 12