1. jtanner's Avatar
    Ive put this under general because it is related to a few things,

    I have followed some guides on getting GPRS / Edge to work using an o2 payg sim...

    My iPhone was AT&T (bought on holiday in NY), i have restored to 1.1.4, and used ZiPihone 2.5c. I have then applied the o2 gprs/edge fix and also reactivated the menu within settings>general>network. Swirly is the latest version

    Now, i appear to be able to send using Swirly, but cannot receive, i keep getting "failed to GET..." & "please check settings"...

    So, i installed Services, and slid the "Edge" switch to OFF...

    When i then switch back to on, i get a pop up of...

    "Incorrect EDGE Settings
    Select your carrier to restore.

    AT&T
    T-Mobile Unlimited
    T-Mobile T-Zones
    Other"

    Is there a way to fix this, or edit the 4 buttons being shown? i had a feeling i had seen it somewhere but im buggerd if i can find it lol

    Many thanks in advance

    James

    Just adding, i realise EDGE is contract, payg get GPRS
    2008-03-04 11:50 AM
  2. phucks1976's Avatar
    Ive got exactly the same step NY phone in Uk. Install boss prefs or services turn edge off wait 10 secs then turn back on. It will prompt u for apn settings again. enter them and it should work fine. By the way which apn settings are you using because I can only get GPRS not edge.

    Paul
    2008-03-04 11:54 AM
  3. jtanner's Avatar
    my apn settings are fine, altho i never get the E icon, even when i send from swirly. perhaps ill try boss prefs....

    the settings im using are:

    apn: payandgo.o2.co.uk
    username: payandgo
    password: password

    EDGE is contract only i think ... payg can only get gprs
    2008-03-04 11:57 AM
LINK TO POST COPIED TO CLIPBOARD