1. mcleafy's Avatar
    Hi

    I have a 3G iphone on 2.2 fw. Before I did anything I had wifi, I then did a jeailbreak with quickpwn with the intention of unlocking, but I had no wifi or bluetooth, it just wont see network. tryed restore several times but no joy. I eventually got the iphone unlocked and jailbroke with quicksn0w but the unlock doesnt last, when I reboot phone I get invalid sim.
    The thing I really want to get working is the wifi. does anyone have any advice/suggestions that could help me?
    Ive tryed rebooting router, resetting network settings on iphone, restoring iphone, pretty much what I could find on a few forums Ive tryed.

    Cheers Mc
    2009-02-14 07:45 PM
  2. Grassmasta's Avatar
    Well, if you upgraded your 3g to the latest firmware (2.2.1), your out of luck. The baseband update spoiled the software unlock for the 3g. And if your still on 2.2, I'd suggest giving jailbreak and yellowsn0w another try.
    Viruses
    Intruders
    Spyware
    Trojans and
    Adware

    Windows Vista
    2009-02-14 08:58 PM
  3. mcleafy's Avatar
    thanks for your reply, I'm still on 2.2 I didnt update to 2.2.1, so baseband is stil 02.28,
    After restoring and jailbreaking so many times to try fix it I thought I'd ask for help.
    I can only use quicksn0w to unlock and jailbreak though, with having no wifi, I've tryed jailbreakinbg with quickpwn also.
    I even tryed the "in freezer" solution some ppl have tryed but no luck, thats what makes me think its software rather than hardware based.
    2009-02-14 09:07 PM
  4. Grassmasta's Avatar
    Ahh, I miss understood you. You lack wifi, ergo you can't d/l yellowsn0w from cydia. I'd suggest going to a public place with free wifi an d/l it there.
    2009-02-14 09:27 PM
  5. mcleafy's Avatar
    srry I aint the best at wording things, I have a wireless router but iphone cant see it since jailbreak 2.2, hence using quicksn0w to unlock

    Mc

    Could it be the baseband causing the lack of wifi?
    Last edited by mcleafy; 2009-02-15 at 12:36 AM.
    2009-02-14 10:14 PM
  6. Grassmasta's Avatar
    Ahh, well your phone should be able to see your wireless router, even if your internet is down. Try going to Settings>General>Reset>Reset Network Settings (I found this here)

    After some research, it appears as though quicksn0w is an unofficial jailbreaking/unlocking method that combines the Dev Teams programs into one package. Until you mentioned it, I had never heard of it. One of the issues with unofficial jailbreaking/unlocking is that there are a number of things that could be done wrong, including wifi calibration. I recall reading about an unofficial windows jailbreak for 2.2.1 a few days before the release of the latest quickpwn for windows. People had issues with it. If the resetting of your network settings doesn't work, Id try to rejailbreak using the official quickpwn, and then unlock using yellowsn0w.

    Hope you get it worked out.
    Last edited by Grassmasta; 2009-02-15 at 05:23 AM.
    Viruses
    Intruders
    Spyware
    Trojans and
    Adware

    Windows Vista
    2009-02-15 05:19 AM
  7. mcleafy's Avatar
    Thanks for your reply m8,
    I have previously restored and done a jailbreak with quickpwn several times and still not got wifi back, do you think its worth trying again?
    When I do the jailbreak I have no option to install yellowsn0w, could yellowsn0w affect the wifi? like if I managed to install yellowsn0w is it possible this could fix the wifi problem.
    Lastly, is there a way to install yellowsn0w without wifi access?

    Really appreciate your help in this I'm just totally lost now after spending over a week at this.
    2009-02-15 01:28 PM
  8. Grassmasta's Avatar
    First things first, did you try to reset your network settings by going to Settings> General> Reset> Reset Network Settings? That seems to have fixed the wifi issue for quite a few folks.

    Second of all, if you've already tried restoring (legitimately) multiple times, I would judge that it probably isn't going to fix your problem.

    Yellowsn0w is available via cydia. In terms of backwards tethering (using your computer's internet connection on your iphone via usb), its fairly complicated, and you need ssh to do it (which you need to d/l from cydia...making this impossible).

    Yellow snow will not fix your wifi issue. It appears as though the only way to install yellowsn0w (without wifi) is the quicksn0w method you were talking about.

    Lets try to get your wifi working before we tackle yellowsn0w. Wifi is essential to the functionality of your phone. Try the Network Settings reset (detailed above) and see if that helps.
    Viruses
    Intruders
    Spyware
    Trojans and
    Adware

    Windows Vista
    2009-02-15 08:51 PM
  9. mcleafy's Avatar
    Hi
    Ive just reset network settings, result is same no wifi, sticks on choose a network. I also checked in settings/about and there is a mac address similar to bluetooth address, so that parts fine.

    How do you mean restore legitamitly? official 2.2 ipsw with itunes?
    If so thats what I've used.
    2009-02-15 09:12 PM
  10. JStraitiff's Avatar
    if the router is 80211n or wpa it wont work
    2009-02-15 09:27 PM
  11. mcleafy's Avatar
    Routers set to 802.11g/802.11b
    Security was set as wpa2, Ive since disabled security
    I had the wifi working on this router when I first got it, all ive changed is disabled security.
    Im tending to think its software based on the phone rather than the router, but lost as to how to repair.

    Dont know if I can post links? but found an interesting thread elsewhere on the wifi issue. Alot of people having similar problems to me, but no fix......still very interesting reading.
    Last edited by mcleafy; 2009-02-15 at 09:38 PM.
    2009-02-15 09:34 PM
  12. Grassmasta's Avatar
    No, I just mean with quickpwn rather than a package that someone else (not the DEV team) has bundled.
    Last edited by Grassmasta; 2009-02-15 at 09:49 PM.
    Viruses
    Intruders
    Spyware
    Trojans and
    Adware

    Windows Vista
    2009-02-15 09:47 PM
  13. mcleafy's Avatar
    Yes quickpwn and quicksnow is what ive used, I did try a restore to 2.0.1 to try fix wifi and used winpwn 2.5 for that. Although that didnt help me so restored back to 2.2 with itunes and then jailbreak with quickpwn.
    These are all the apps I've used.
    2009-02-15 09:54 PM
  14. Grassmasta's Avatar
    It seems as though some people have had to exchange their phones because of issues like this. So your problem may be a hardware issue. I recommend that you read apples support here.

    Good luck.
    Viruses
    Intruders
    Spyware
    Trojans and
    Adware

    Windows Vista
    2009-02-15 10:53 PM
  15. mcleafy's Avatar
    Yes I saw alot had to get their phones returned, I still think its software based, perhaps more hoping it is right enough lol.
    Funny it happened after 1st jailbreak, almost as if it was payback for jailbreaking? Or am I just being paranoid about apple....

    Thanks for your help so far much appreciated m8

    Thinking back to when I lost the wifi.....If I remember right I dont think it was after the jailbreak I think it was defore, I was testing how far I could get the wifi signal in the house and it went off as I went out of signal from the router...I dont know if thats significant or not. So maybe hardware right enough
    Last edited by mcleafy; 2009-02-15 at 11:40 PM.
    2009-02-15 11:14 PM
  16. Grassmasta's Avatar
    Not a problem. I hope you get your situation is remedied soon. (if you do decide to take it in to an apple store, remember to restore to an unjailbroken firmware)
    Viruses
    Intruders
    Spyware
    Trojans and
    Adware

    Windows Vista
    2009-02-16 12:45 AM
  17. punklove's Avatar
    Apple - Support - Discussions - iphone 2.1 firmware / wifi cannot ...

    okay, so i've been struggling with the no wifi issue- happen either when i upgraded to 2.1 or 2.2- i dont remember, its been awhile- but I've been searching for weeks to figure this out.

    the second to last post in the thread linked above sounds unreal, it is cut and pasted below-

    ""
    This problem started after I upgraded from 1.1.4 till then it worked fine.
    This is a firmware issue. Apple where trying to fight two issues.
    a. Over heating
    b. Poor battrey life.

    So they did some **** in the firmware which stops over heating and which extends battrey life. But the wifi chip didnt like this.

    I have dedicated over 3 weeks of my life to trying to fix this. And trust me if I couldnt you cant. So if you have this issue. Write to apple make a noise.

    Have gone down to kernel level debuging. What is happening is that the wifi is going into sleep mode / power saving mode and is unable to wake up.

    Try putting your phone into the freezer freeze it. Let the buttons thaw out cause they will crack if you try to use them in frozen state. And you will see your wifi is up and runing.

    If apple wanted to fix this it would be very simple. They only need to release a fix. Which allows us to go back to the power settings as used on the 1.1.4 firmware.

    The problem is they are shafted either way. Enable the wifi to work and people will ***** about over heating and poor battrey life. Or leave it like this. This way at least 90% of the people will not complain.

    Only way to get this wifi issue sorted is for customers to press apple into releasing a fix.
    Other than this issue their TCP/IP stack *****. But at least get the wifi chip to work or make it possible for people to buy these wifi chips / com boards.
    ""
    happiness is a warm iphone~~~~
    2009-03-04 11:38 PM
  18. stereosympathy's Avatar
    Well, if you upgraded your 3g to the latest firmware (2.2.1), your out of luck. The baseband update spoiled the software unlock for the 3g. And if your still on 2.2, I'd suggest giving jailbreak and yellowsn0w another try.
    I'm running a 3g with the upgraded firmware, no issues at all. I originally jailbroke it with custom 2.2.1 software but recently downgraded to 2.2 but still have firmware 2.30.03.
    2009-03-05 06:13 AM
LINK TO POST COPIED TO CLIPBOARD