1. eightdown's Avatar
    I need some help please. My iphone won't connect to data network unless I turn 3g off and on. If the iPhone is put on autolock, when I turn it back on, I have the same issue. Any suggestions?
    2009-03-31 02:23 PM
  2. imnothardcore's Avatar
    apple store!
    make it a great day!
    2009-03-31 03:42 PM
  3. Poseidon79's Avatar
    If you're unlocked and trying to use your iphone 3G on t-mobile this is normal. However you have given absolutely no information as to your service provider, country, or unlock status that I can only speculate. More info!
    2009-03-31 03:45 PM
  4. eightdown's Avatar
    It's a jailbroken rogers (Canada) 8gb 3g 2.2.1. Modem firmware 02.30.03. I've had the phone for several months and there has never been an issue until yesterday. Haven't done anything to it lately other than uninstalled a few apps I don't use.
    2009-03-31 03:55 PM
  5. Poseidon79's Avatar
    Well have you tried to reset your network settings? settings - general - reset - reset network settings. If this doesn't work a full restore would be needed to truly see if it's hardware failure.
    2009-03-31 04:03 PM
  6. eightdown's Avatar
    What's strange is it seems to be working fine again. It did this yesterday too. I had data connection issues in the morning but then it cleared up a couple hours later. I'm at work and my signal strength is maximum so it isn't having trouble with signal, I know that much. I will reset the network settings and see if that stops it from happening again but it looks like I may just restore it to give it a clean start. I've had a couple other minor issues anyway. I was just hoping I didn't have to.
    Thanks for your help by the way.

    Well, the network reset didn't work so I had to do a full restore and rejailbreak it. It's working a lot better (faster and smoother) now. Just have to figure out what apps I need and what I can do without in order to keep it this way.
    Last edited by eightdown; 2009-04-01 at 02:25 PM. Reason: Automerged Doublepost
    2009-04-01 02:25 PM
LINK TO POST COPIED TO CLIPBOARD