1. justin7942163's Avatar
    Hey modmyi community!

    Long story short I got my iPhone from a guy I work with for $50.

    3G iPhone 50 BUCKS!! What a steal! Has a few scratches on the back and sides but they cover up nice with a case. I've jail broken it and everything works expect for the phone side of things (Text messaging and calling)
    Anyway it is LOCKED to Optus Mobile.

    I use Telstra and I want to stay with Telstra.

    Thing is its 2.2.1 no yellowsn0w thus far.

    So I brought a Turbo sim for it 3 days ago.

    I got the turbo sim today but I'm having trouble with it.

    I'm using a Normal Telstra sim card not a next G I have Firmware 2.2.1 and Modem Firmware 02.30.03

    I've put the sim in a few times and I've restarted the phone quite a number of times but I get nothing all I get is "No SIM card installed"

    I've followed videos on you tube and still I get nothing!

    My about page says:

    Network...........................Not Available
    Songs.............................309
    Videos............................11
    Photos............................63
    Capacity.........................7.1 GB
    Availble..........................2.7 GB
    Version..........................2.2.1 (5H11)
    Carrier...........................OPTUS 2.9
    Serial Number.................--- Tell you if its needed ---
    Model............................MB489X
    Wi-Fi Address................00:25:00:7A:59:6B
    Bluetooth.......................00:25:00:7A:59:6A
    IMEI.............................01 181200 899032 2
    ICCID............................
    Modem Firmware.............02.30.03

    Right now, I'm stumped as to what to do, I don't really want to fork out $100 bucks to get a shop to do it if there is a way to fix my iPhone with this turbo sim.

    Any help please?
    Internet killed the video star.
    2009-04-29 12:22 PM
  2. lach's Avatar
    Telstra is good .

    alright, first of all do you have any idea as of how old the iPhone is?
    depending on when it was made, the iPhone bootloader differs, and depending on what version bootloader you have, will depend on if you can unlock your iPhone with software, (so for now we wont worry about the turbo sim).

    goto this site, and follow the tutorial, iClarified - iPhone - How to Check Your iPhone Bootloader Version (Windows) On this site you will find out what version bootloader you have. This is important, as at the moment only bootloader 5.8 is able to have the baseband downgraded for unlock with yellowsn0w.

    so, what bootloader do you have? 5.8? Continue


    To unlock your iPhone, you need to downgrade your Baseband, from 2.30 to 2.28 for iPhone 3Gs, but to do this you need the 5.8 bootloader (i gave you the link to guide you on how to find what version bootloader you have)

    If your bootloader is version 5.8, then goto this site, iClarified - iPhone - How to Downgrade Your iPhone 3G 2.30 (2.2.1) Baseband for Unlock which will guide you on how you can downgrade your iPhone Baseband so you can unlock it.



    Sorry about all this, haha it must be the most confusing post ever, but it is a lot of info to take in. I was unsure of y the turbo sim was not working, therefore i figured if you could unlock your iPhone by using the official 3G unlock yellowsn0w, it would be heaps easier.
    Last edited by lach; 2009-04-29 at 12:57 PM. Reason: Automerged Doublepost
    2009-04-29 12:53 PM
  3. confucious's Avatar
    Where did you get your TurboSIM? Older ones will not work. I would just buy another one off eBay that they guarantee will work with your BB.
    As for the option of taking it to a shop - forget it! The ONLY way of getting BB 2.30.03 to work with an unofficial carrier in a locked phone is a piggyback SIM.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-29 01:15 PM
  4. lach's Avatar
    ^^ Optus will unlock your iPhone for any carrier, someone i know recently purchased (couple of months ago) a iPhone 3G 16GB from optus, and payed $120 i think it was, to get it unlocked. This is still an option, because a friend of mine is now on telstra! (therefore unlocked through optus)
    2009-04-29 01:24 PM
  5. confucious's Avatar
    Ah! I meant to say, apart from if your carrier will give you an official unlock....

    O2 in the UK wont and I forgot that option. Worth giving them a ring to find out.
    Having said that, if you only paid $50 for it, are you sure it's legit?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-29 01:27 PM
  6. justin7942163's Avatar
    Telstra is good .

    alright, first of all do you have any idea as of how old the iPhone is?
    depending on when it was made, the iPhone bootloader differs, and depending on what version bootloader you have, will depend on if you can unlock your iPhone with software, (so for now we wont worry about the turbo sim).

    goto this site, and follow the tutorial, iClarified - iPhone - How to Check Your iPhone Bootloader Version (Windows) On this site you will find out what version bootloader you have. This is important, as at the moment only bootloader 5.8 is able to have the baseband downgraded for unlock with yellowsn0w.

    so, what bootloader do you have? 5.8? Continue


    To unlock your iPhone, you need to downgrade your Baseband, from 2.30 to 2.28 for iPhone 3Gs, but to do this you need the 5.8 bootloader (i gave you the link to guide you on how to find what version bootloader you have)

    If your bootloader is version 5.8, then goto this site, iClarified - iPhone - How to Downgrade Your iPhone 3G 2.30 (2.2.1) Baseband for Unlock which will guide you on how you can downgrade your iPhone Baseband so you can unlock it.



    Sorry about all this, haha it must be the most confusing post ever, but it is a lot of info to take in. I was unsure of y the turbo sim was not working, therefore i figured if you could unlock your iPhone by using the official 3G unlock yellowsn0w, it would be heaps easier.
    I followed the tutorial and it worked! But unfoutunatly my Baseband is 6.something (I didnt get to write it down as my iPhone rebooted itself) not the 5.8.

    Do you know of any other ways?

    Thanks though mate.
    Internet killed the video star.
    2009-04-29 02:37 PM
  7. lach's Avatar
    At this stage, only the 5.8 Bootloader has an exploit which enables software to downgrade the baseband from 2.30 to 2.28.

    Therefore, at the moment your only chance is either getting optus to unlock it, or using a turbo sim etc, which i am not to familiar with, sorry. Good luck anyways man,
    2009-04-29 03:53 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.