1. Y-not's Avatar
    When I write something whether ıt ıs sms or on facebook, iphone suggests these stupıd words that do not make any sense and even ıf ı dont clıck on ıt to choose it, ,t still writes it instead of the correct word.

    How can this stupid thing be turned off?

    thanks
    2008-03-12 10:52 AM
  2. echo's Avatar
    When I write something whether ıt ıs sms or on facebook, iphone suggests these stupıd words that do not make any sense and even ıf ı dont clıck on ıt to choose it, ,t still writes it instead of the correct word.

    How can this stupid thing be turned off?

    thanks

    You can install something called "kb2" under the "Tweaks 1.1.1". It adds a setting in your keyboard preferences (Settings/General/Keyboard) to enable or disable the auto-correction feature. Works on 1.1.4

    cheers,
    e
    15.4" 2.8GHz Unibody MacBook Pro
    Pwnage Unlocked 16GB iPhone (2.1)
    Apple Unlocked 16GB 3G iPhone (2.2)
    2008-03-12 11:10 AM
  3. Y-not's Avatar
    thanks much for your quick reply. ıt worked great
    2008-03-12 11:29 AM
  4. Rustynuts's Avatar
    sweet never knew about that either, cheers works a treat on 1.1.4
    2008-03-12 11:33 AM
  5. allbuss's Avatar
    it doesn't show up in the tweaks 1.1.1 section. even after i refresh how many times, it still doesn't show up. how do i add kb2 manually?
    2008-04-05 07:44 PM
  6. echo's Avatar
    it doesn't show up in the tweaks 1.1.1 section. even after i refresh how many times, it still doesn't show up. how do i add kb2 manually?
    It should show up under Tweaks (1.1.1) as this little bit of code was release by Ste that is part of the Community Sources in Installer (he was the first Community Source if I'm not mistaken). At any rate, here's his website...

    http://blog.psmxy.org/

    If you click on "Pkg Info" you'll see kb2 listed along with other apps.

    good luck,
    e
    15.4" 2.8GHz Unibody MacBook Pro
    Pwnage Unlocked 16GB iPhone (2.1)
    Apple Unlocked 16GB 3G iPhone (2.2)
    2008-04-05 08:31 PM
  7. allbuss's Avatar
    i found out what the problem is now. i bought my iphone from a friend of mine. he told me he installed kb, and then uninstalled it. could that be a reason for it not showing up in tweaks 1.1.1? it should though right? i rebooted and refreshed a couple times already, and it's still not showing up. is there any way around this?
    2008-04-05 08:56 PM
  8. koompi's Avatar
    You can hit the suggested word and it'll go away and you can continue typing.

    I think it should be the other way personally.
    If you misspell or spell one it doesn't recognize, it should give you the suggestion but you should then hit it if you want that or not; having it do it automatically is annoying.
    2008-04-05 09:20 PM
  9. zsuns's Avatar
    Under utilities, look for "Kb2" then once installed, go to settings--general setings--keyboard settings---Auto corection OFF
    A Thanks is always nice =]
    2008-04-05 10:57 PM
  10. allbuss's Avatar
    it's not under utlities. in fact, i searched under 'all packages' and still no luck. oh wells. should i try uninstalling and reinstalling the source so that it refreshes properly?
    2008-04-06 01:02 AM
  11. mthoene's Avatar
    hate to revive an old thread, but I was wondering if there was any way to edit the file that suggests words, possibly with SSH?
    2008-10-19 06:35 PM
LINK TO POST COPIED TO CLIPBOARD