1. drpeppir's Avatar
    The wifi worked for 1 day after i upgraded, now it shows networks available but I am no longer able to connect to ANYTHING!!!!

    this is horrible! I have run through every possible solution and nothing the wifi is absolutely gone!

    In addition attempts to warranty my factory unlocked phone will result in me getting a factory locked phone in exchange!!! The money i paid for the factory unlocked phone is going to go down the drain due to apple's incompetence at testing firmwares
    2009-06-26 07:55 PM
  2. S550Benz's Avatar
    iPhone - WiFi connected to router, but not to internet - Mac-Forums.com

    I had the same problem as you but then I just followed those instructions and the wifi on both my iPhones worked.
    2009-06-26 09:57 PM
  3. drpeppir's Avatar
    Uhh that solution works only if you are able to actually connect to the router... after the 3.0 update i was able to connect to my router and do everything for about 24 hours after which i got the error message "unable to connect to 'Router-Name'" and it never connected again. IN OTHER WORDS, it will NOT let me join any network no matter how new or old it is whether I downgrade, reset, reinstall etc!

    Trust me I have reset network typed in static reloaded the firmware, downgraded. The only thing that makes sense is that it's related to the update.
    2009-06-26 10:56 PM
  4. arram's Avatar
    Yeah I also had that problem. I downgraded to 2.2.1 but my wifi is greyed out and sometimes comes back but i still cant connect to any spots. Also my battery is still bad even tho i downgraded it to 2.2.1. I have tried everything possible but wifi never came. I have an appointment with genius bar tomorrow so hopefully they replace it
    2009-06-27 12:31 AM
LINK TO POST COPIED TO CLIPBOARD