1. theguy386's Avatar
    So anyone else having problems with battery draining really fast on 3.0?

    I noticed that it's only when browsing the web, watching a youtube video, checking email... pretty much anything that involves getting data over 3g or wifi.

    Just now I started with 78% of battery and after watching a 2:35 youtube video it jumped to 73%

    I miss the battery life on 2.2.1
    2009-06-28 04:10 AM
  2. blckcamaross's Avatar
    One guy on another forum stated that after he jailbroke it, he had very bad battery life and heat issues.

    He said that he rejailbroke it and instead of "backing up" the iphone, he just synced it and it solved his issues.

    I did it, and it worked for me.
    2009-06-28 04:17 AM
  3. cpjr's Avatar
    Yeah using a backup file after jailbreak is seemingly causing alot of issues.
    2009-06-28 05:28 AM
  4. theguy386's Avatar
    hhmmmm, thats odd because I set mine up as a "new iphone" when I did the 3.0 update
    2009-06-28 05:33 AM
  5. tellytel's Avatar
    Turn your push off. There are a lot of people having this problem. Turn off push, reboot and battery should be back to normal. Hopefully they fix it soon.
    2009-06-28 07:57 AM
  6. happypappy's Avatar
    This is rediculous. I updated to 3.0 and battery life was horrible. Then jailbroke using Pwnage3.0.....and just watched the battery % drop like crazy. Then thought maybe it was a buggy jailbreak so I then re-jailbroke with Pwnage and still battery issues. So restored nack to factory settings and used the phone a day without jailbreaking.....same thing bad battery again. Then jailbroke with redsnow instead. STILL ISSUES.....my battery was at full charge and then start using the phone for checking mail, a couple quick replies with irealsms and checking my rss feeds(all like average normal use for me) and literally watching the % drop right in front of my eyes. Standby time is fine......the phone was in standby from 237am till 11am and was at 99%....good stuff....but then start using the phone and bye bye battery.....and yes all my restores and jailbreaks were all fresh installs and no backups used. And yes PUSH is turned off and brightness is 70%...... What could be the issue?
    2009-06-28 05:15 PM
  7. njr1489's Avatar
    I've had the same problems as well, but if this re-jailbreaking method works, i'm willing to give it to a try.
    2009-06-28 05:20 PM
  8. wildgene789's Avatar
    i bought the morphie battery pack and i must say wow ahah i dont have to worry about anything
    2009-06-28 05:35 PM
  9. boe_dye's Avatar
    here are my two experiences thus far, one was with backup restore settings and the other was without backup restore settings, in both cases I did not upgrade but instead did a factory restore:

    After doing a factory restore with 3.0, and before jailbreaking I restored my settings with the previous back up. Two things I noticed was that many features where still implemented; Categories, Custom Carrier Logo, Poof'd Icons, ETC.

    Battery Life was so-so. It did drain noticeably faster then before, which was somewhat odd because 3.0 was supposed to be slimlined and leave less of a memory footprint.

    After jailbreaking, my batter life became non existant. I stream alot of internet radio, and don't really use the iPod much... Basically what happened was is that I was in my workshop listening to radioBOX, with my iPhone Dock'd and "charging" when suddenly the music stopped. My first thought was that it timed out, however when I looked over at my iPhone in the dock, it had completely turned off. Again it was in the dock charging, and something was going on where the charger could not keep up with the drain.

    Once everything was nice and charged again, I went back to my computer, and started from scratch. I did a complete restore again, did NOT restore from backup, and then re-jailbroke from redsn0w.

    This time around, just about everything works pretty well, my battery life is back to normal, and I haven't had any noticeable issues with the battery.

    So I believe that the key to many of the problems lies in "Restore from Backup". I believe that the "Restore" contains what us windows user would consider as a registry (this is just a guess on my end as i have not really gotten a straight answer on this issue). Certain things like Carrier Logo's, and Poof and Categories are for all intent and purposes simple modifications.

    Taking these simple modifications from 2.0 to 3.0 works to some degree, however some system type things are more complex. For example modifying the mobile substrate in order for backgrounder to work, compared to "turning off" and icon by flipping a 1 to a 0 is much more involved (again this is just an educated guess based on experience).

    So it is my GUESS, that there are simply incompatibilities that carry over in a restore from backup.

    Best solution: Don't restore from backup. Generally speaking, there really isn't a whole lot to be gained from restoring from backup anyways. All it really does is helps you not having to manually reinsert information such as your account information, and I believe that it does restore settings and things that you might have saved in your apps as well, which I suppose can be important if your are really that upset at losing your high score in TapTapRevenge.

    In the factory restore, all of your information is wiped anyhow. You will still need to sync your apps, music, and contact information which is already backed up in their respective places.

    And you should always do a factory restore when upgrading and jailbreaking anyways.

    So again, the best solution is to do a factore restore, which can be accomplished through iTunes, and NOT restore settings from a backup.

    Syncing will pretty much put 99% of what you had back together, minus of course the above mentioned settings of certain things.
    Herp a derp a derp a doooo!
    2009-06-28 05:46 PM
  10. theguy386's Avatar
    so it seems like I'm not the only one dealing with battery issues in 3.0

    damn 3.0
    2009-06-28 06:27 PM
  11. njr1489's Avatar
    I tried to re-jailbreak my iPhone but nothing really happened. It's getting rediculous to the point where it can't even standby for more than 4-6 hours. I might just go back to 2.2.1, the battery life is just not worth it.
    2009-06-29 12:39 AM
  12. happypappy's Avatar
    Check the apple forums, there are TONS of posts about bad battery life. Jalibroken or not. I was using my 3G UN-Jailbroken and battery life was still horrible. All my restores were all set to new phone and full factory settings. Jail broken or not the battery life is still junk. I want to go back to 2.2 also now. :-(
    2009-06-29 01:26 AM
  13. njr1489's Avatar
    Update on my status:

    Well so far I did a factory restore and did a back up from when it was on 3.0, used redsnow to jailbreak it again. The battery life is ok, which is now the least of my worries for now. Then again, I could be paranoid since I have my batter status show the percentage. My biggest annoyance now is how I get a pop up each time I lose service and I don't know how to remove it.

    On an irrelevant note: SSH works as long as I install open SSH.

    EDIT: Battery life is still as bad as before.
    Last edited by njr1489; 2009-06-29 at 10:16 PM.
    2009-06-29 04:36 AM
  14. hoeroLLa's Avatar
    was this because of some apps downloaded from **********?

    my battery was fine before I downloaded apps from ********** but after a couple of applications, my battery drains noticeably fast.

    is there a bug or a file that i could look up using SSH to fix this problem? thanks.
    2009-08-04 09:43 AM
LINK TO POST COPIED TO CLIPBOARD