1. Barong's Avatar
    Hi evereyone !

    I'm new on the forum.
    I hope someone can help...

    I'm sorry to say that I already posted this message on another forum, but as I have no reply and really need one, I think maybe someone here can help :-)

    I want to rename some of my apps. I install Rename. Works fine for all
    the apps but the native ones.

    For the native ones, I've found something on the web to do it : I ssh
    into my iphone, edit info.plist of the app, find CFBundlename and
    rename the app. That's just as easy...

    I've tried with Calculator to be sure. But info.plist doesn't really
    look like the other apps. But I've found the name "Calculator" and
    tried to rename it to "Calc". Then I uploaded the text file, resprung,
    and OH :angry: the app Calculator is not there anymore.

    Of course, I've tried to do all these steps again and rename it back
    to Calculator, respring, but nothing, reboot, nothing...

    Please someone help me.

    It's not like I really need this app, but I really don't like the idea
    of loosing some apps without knowing why.

    Thanks.....!!
    2009-07-30 02:29 PM
  2. BlackWolf's Avatar
    that's probably because you edited the file before you converted it to a human-readable format.
    the file is permanently damaged in that case. I uploaded my Calculator's Info.plist, I guess that should do the trick (you need to rename it from .txt to .plist)

    If you want to edit .plist and they are not in a readable format, you should convert them using plutil. To get plutil, you need to install "erica's utilities" from cydia. after that, execute the following on your iphone:

    plutil -convert xml1 YOURPLISTFILE

    I can't tell you where to enter that command because it differs depending on what program you use to ssh into your iphone. you need to get in some kind of terminal envoirnment to do it. but if you found out how to do it once it's really the most easy way to convert those files.
    Attached Files
    2009-07-30 10:31 PM
  3. Barong's Avatar
    Thank you for your answer.

    I downloaded your file, renamed it to info.plist, put it back to the directory where the original file was located.

    But even after rebooting the iphone, the icon is still not there. I used WinSCP to do it.

    You can see with the print screen below that everyting seems to be fine.

    Or maybe after transfering the new plist, there is something else that has to be done ?

    Thank you so much !
    P.

    2009-07-31 12:31 PM
LINK TO POST COPIED TO CLIPBOARD