1. neilo's Avatar
    Hi All,

    This is my first post to the forums - I hope someone can help !

    I recently installed the imobilecinema(2.2.27643)plugin for Safari onto my iPhone 3GS. It didn't seem to work correctly under firmware 3.0.

    I have tried to uninstall via cydia but the plugin is still there, it takes over whenever I try to stream content using the BBC iPlayer and I'm then not able to stream content in the browser.

    I've tried re-loading and uninstalling again, and also downloaded a toggle for SBSettings but neither of these have removed the plugin from Safari.

    Has anyone any ideas about how to remove the imobilecinema plugin from my phone ?

    Thanks in advance,

    Neilo

    *** Update ***

    I was able to SSH to iphone and confirm that the three imobilecinema folders had been correctly uninstalled.

    My problem with Safari streaming was still there. After more digging, it turns out that I had mis-diagnosed my problem. The concern was due to me having the "Safari Download Plugin" installed. This was installed automatically along with dTunes player but was not removed when I uninstalled dTunes.

    I've now removed the "Safari Download Plugin" via Cydia, and my ability to stream has returned !!! :-)

    Cheers,

    Neilo
    Last edited by neilo; 2009-08-10 at 04:04 PM. Reason: Automerged Doublepost
    2009-08-10 04:04 PM
  2. loesak's Avatar
    I am having similar problem. Iphone 3gs with 3.1.2. I installed imobilecinema and it seemed to work mostly (no sound). I then noticed that other video that played before w/o the plugin now just displayed the video stream content. I uninstalled the plugin via cydia and verified the folders were removed as per imobilecinema's instructions. I did not have the safari download plugin installed. i installed and uninstalled hoping this would resolve my issue. It seems that safari doesn't know how to handle the mp4 mime type anymore.

    any help? was something else installed with imobilecinema that i need to remove?

    any help would be appreciated.

    thank you
    2009-11-13 06:39 AM
  3. liutszho's Avatar
    Which folders need to be removed?

    I can't play mobile video files on m.youtube.com now after uninstalling it from cydia
    2009-11-14 07:16 PM
  4. HungryHungryNico's Avatar
    SSH or use iFile to travel to System/Library/Internet Plug-Ins. I think it may be located there.
    2009-11-14 07:55 PM
  5. liutszho's Avatar
    I tried removing the folder but still didn't fix it

    ugghhh anyone manage to solve this problem?
    2009-11-14 08:52 PM
  6. se23's Avatar
    How come yours dnt work? Mine is fine
    2009-11-14 09:06 PM
  7. loesak's Avatar
    I think that I may have gotten lucky and I restored my iPhone to a backup that I took the day before installing imobilecinema. I think I am going to make this a practice from now on. I know this may not help anyone, but it wasn't something that I thought about when I sent the original post.
    2009-11-14 09:14 PM
  8. liutszho's Avatar
    I even uninstalled the safari download plugin.

    But still won't work
    2009-11-14 09:59 PM
  9. se23's Avatar
    try re-install imobilecinema and get the sbsettings toggle. you might be able to turn it off and then it might work ok, just a thought before u restore
    2009-11-19 05:43 PM
  10. freezethetime's Avatar
    well, i know im some months late but here it is!!!

    Uninstall iMobileCinema

    If you installed an incorrect version of iMobileCinema, or iMobileCinema just not works in your iPhone, even crashes the Safari, you may want to uninstall it.

    For Installer or iBrickr
    You can uninstall iMobileCinema directly from Installer or iBrickr.

    For Windows application installed iPhone
    You need delete three paths manually: "/System/Library/Internet Plug-Ins/iMobileCinema/", "/var/mobile/Library/iMobileCinema/" and "/var/mobile/Media/iMobileCinema/". Usually, we connect iPhone though an SSH client.Type in the terminal,
    rm -rf /System/Library/Internet\ Plug-Ins/iMobileCinema
    rm -rf /var/mobile/Library/iMobileCinema
    rm -rf /var/mobile/Media/iMobileCinema

    /var/mobile/Media/iMobileCinema doesn't exists on iMobileCinema 2.x version.

    from http://imobilecinema.com/uninstall.html

    EDIT: since it didnt work for me i checked further into it so here it is THE SOLUTION: open the youtube app if u get cannot connect to youtube u are the same as i was 2minutes ago . Now add a new cydia repo ( cydia.pushfix.info ) e try using one of the three youtube fix # ONE AND ONLY ONE AT TIME!! the number fixed my phone ;D
    Last edited by freezethetime; 2010-03-22 at 12:55 AM.
    2010-03-22 12:34 AM
LINK TO POST COPIED TO CLIPBOARD