User Tag List

  1. antnida's Avatar

    I tried to created an image for a long time now but never got through, please help point out what I need to do next to dump a successful image.

    1) JB my 3GS
    2) Installed open terminal on my 3GS
    3) Installed WinCSP and Cygwin on my winXP laptop (only computer I have)
    4) using open terminal on my 3GS and typed ssh [email protected] and type in the PC password. Works greats.
    5) open Cygwin and type ping iphone-ip and got replies so I know that both the phone and the computer is talking to each other.
    6) Type dd --version on my 3GS and Cygwin and both showed that dd is installed.
    7) Tried the dd command. dd if=/dev/disk0 | ssh [email protected]’sIPaddress ‘dd of=iphone-dump.img’ and got bash: dd: command not found

    I tried to replace disk0 with rdisk0 s=1M and no luck. Tried on the PC end with dd command and still no luck. Got the same message that dd not found. Any tips to help me get through this stage?

    2009-11-05 04:01 AM
  2. bingbang's Avatar

    The whole shebang:
    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=iphone-dump.img

    Just the system partition:
    ssh [email protected] dd if=/dev/rdisk0s1 bs=1M | dd of=iphone-root.img

    Just the user data partition:
    ssh [email protected] dd if=/dev/rdisk0s2s1 bs=1M | dd of=iphone-user.img

    Are these commands run from the iphone end or the computer?

    I too have been having difficulty getting the DD to start. have Iphone3GS freshly restored and Jail broken and PowerBook(10.4.11) and another laptop running Ubuntu.
    2009-11-07 07:20 PM
  3. seseberg's Avatar
    guys, pardon the interruption, but I think that the best way of doing this would be directly through the USB cable, am I right? because wi-fi seems to just take FOREVER....

    I have been able to ssh into my iphone from my laptop running ubuntu 9.10 over the usb cable, but I haven't been able to do it the other way around. Do any of you guys have any ideas on this?
    2009-11-21 07:56 AM
  4. cliffclof's Avatar
    I'm from Italy.*
    *So it seems to work OK, but starts to save the file "iphone-dump.img" directly on the iPhone. Even if space was sufficient (it is now virtually empty), it is risky and the data have already been lost may never be more readable?*

    You would be lucky to transfer that data and get anything out of it. You should definitely NOT write anything to your iPhone because it writes over your data you are trying to recover.

    2010-01-12 02:14 AM
  5. Ker0r0's Avatar
    How about create a tar ball instead of using dd? How can u SSH over the USB cable?
    2010-03-04 04:19 PM
  6. cliffclof's Avatar
    You can ssh over usb using ubuntu.

    take a look here:

    [ame=]Ipod Touch/phone How-to Usb Music Transfer!!! WORKS - iPod touch Fans forum[/ame]

    [ame=][SOLVED] [How-to] iPod Touch and iPhone under USB with iFuse in Karmic Koala! - Ubuntu Forums[/ame]
    2010-03-04 10:46 PM
  7. Ker0r0's Avatar
    Thanks, I will give it a try in my Ubuntu VM
    2010-03-05 01:02 AM
  8. Ker0r0's Avatar
    Hi, I wonder if transfer time can be greatly reduced by pipe to gzip before sending data to remote side, command need to be issued in iPhone:

    dd if=/dev/rdisk0s1 bs=1M | gzip | ssh [email protected]_server dd of=iphone-root.img.gz
    2010-05-04 04:57 PM
  9. Free Lancer's Avatar
    Trying to recover data off my Iphone 3GS to MAC VM and I tried using this guide, however, I um unable to run DD as I cannot get the filesystem to unmount or mount as read only and I keep getting 'Resourse Busy' error. Please see my logs here:

    localhost:~ root# df -kh
    Filesystem Size Used Avail Use% Mounted on
    /dev/disk0s1 750M 497M 246M 67% /
    devfs 28K 28K 0 100% /dev
    /dev/disk0s2s1 15G 142M 15G 1% /private/var

    localhost:~ root# dd if=/dev/disk0s2s1 bs=4096 | ssh [email protected] 'dd of=iphone_reclaim.img'
    dd: opening `/dev/disk0s2s1': Resource busy

    0+0 records in
    0+0 records out
    0 bytes transferred in 0.000035 secs (0 bytes/sec)

    localhost:~ root# dd if=/dev/disk0s2s1 bs=1M | ssh [email protected] 'dd of=iphone_reclaim.img'
    dd: opening `/dev/disk0s2s1': Resource busy

    localhost:~ root# mount -o ro /private/var
    mount_hfs: Resource busy

    localhost:~ root# mount -o ro force /private/var
    force on /private/var: Operation not supported by device
    localhost:~ root#

    I downloaded umount from somewhere and scp'd it to Iphone:

    MacAdmin$ scp ~/Desktop/Iphone\ FW/umount [email protected]:/sbin/
    [email protected]'s password:
    umount 100% 15KB 14.6KB/s 00:00

    localhost:~ root# umount -f /private/var
    localhost:~ root# mount -o ro /private/var
    mount_hfs: Resource busy

    Might go bald pulling my hair......any help? How is the rest of world doing this?
    2010-06-03 06:09 PM
  10. Ker0r0's Avatar
    You don't need to umount, just mount as read only:

    mount -o ro /
    mount -o ro /private/var

    and you need to use the /dev/rdisk:

    for rootfs:
    ssh -p 2222 [email protected] "dd if=/dev/rdisk0s1 bs=1M | gzip -c" | cat > iPod3-rootfs-rdisk0s1.img.gz

    for user data:
    ssh -p 2222 [email protected] "dd if=/dev/rdisk0s2s1 bs=1M | gzip -c" | cat > iPod3-userfs-rdisk0s2s1.img.gz

    I use USB connection in the above example and you can take out the "-p 2222" if you use WiFi.
    2010-06-04 04:09 AM
  11. KaiserAlucard's Avatar
    I know it's an old thread but you seem to be the ones who are the more able to help me. I lost all my data on my iPhone and I'm desperately trying to recover it without success. I try to follow your advices here but I must say I suck completely at it, it's like chinese to me.
    Would someone be really kind to make a step by step (and I really mean it) method to recover data from an iPhone? Either on Windows 7 or Ubuntu (I installed it with Wubi Ubuntu but I don't know anything about Ubuntu), the easiest the better. I'd be really grateful if you could help me because I'm really in trouble right now.
    Thanks in advance.
    Last edited by KaiserAlucard; 2010-07-27 at 10:51 AM. Reason: typo
    2010-07-27 10:51 AM
  12. kenpura's Avatar
    man.. that was the best thing i've read on this site in ages. kudos to you sir.
    2010-07-27 09:18 PM
  13. cindykelly's Avatar
    Poseidon79 - While I can appreciate the suggestion, what would that accomplish? My data is still largely in place on the phone, but still unaccessible. I was under the impression that iTunes had properly made a backup in the first place. Every time I do a backup using iTunes, I now double check that the file dates are fresh, but that doesn't change the fact that my original data is still irretrievable. What would I research? Apple's ineptitude and utter disregard for a sizable segment of its clientele? How would I correct the problem? Should I whine about how iTunes failed until Apple doesn't think different? I do what makes sense and is in my power - that is recover a bit-for-bit dump of the file system.

    guisquil - LOL! The full commands are below. There's no easy way that I've found to get a progress indicator with dd. Depending on the speed of your wireless network, it could take from 6-10 hours for the entire drive.

    cyclonefr - Great, it works! Alright, the first string you provided using /dev/disk0 didn't work, but /dev/rdisk0 did. I had used the block size parameter with disk0 as per and it still had issues. However, I never tried using the bs option with rdisk. Good call on discovering that! This has saved a lot of time and aggravation, so thank you immensely!

    The whole shebang:
    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=iphone-dump.img

    Just the system partition:
    ssh [email protected] dd if=/dev/rdisk0s1 bs=1M | dd of=iphone-root.img

    Just the user data partition:
    ssh [email protected] dd if=/dev/rdisk0s2s1 bs=1M | dd of=iphone-user.img

    This is the most helpful thing I've got. It is really helpful. Somehow I am stucking on dd image.

    dd if=/dev/disk0s2s1 doesn't work for me. Resource busy.

    Following Miscreanity's instruction by using
    dd if=/dev/rdisk0s2s1 bs=1M

    I got "Invalid argument"

    Am I missing the tricky part?

    I do appreciate for all your help! Million thanks!!!
    2010-08-07 10:00 AM
  14. jbob0124's Avatar
    Don't mean to bump an old thread, but Im trying to copy an image to my computer using this method. If I run this,

    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=iphone-dump.img
    it comes up with the user password prompt. The problem is I don't know the password, its not 'alpine' or 'dottie' Is there a way to change the password once you are logged in under the iphone on the terminal through the computer? Also, what if you ran it as "root" instead of "user" wouldn't that achieve the same thing?
    2010-08-15 05:07 PM
  15. surrapurra's Avatar
    I have the same problem. Could this have something to do with firmware, cause we have propably way newer versions now? Anyway, when I use:

    dd if=/dev/disk0 | ssh [email protected]’sIPaddress ‘dd of=iphone-dump.img’

    it makes a dump with nothing in it and when I use:

    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=iphone-dump.img

    I have the same problem that it asks iPhone's password instead of my computer.

    Should I be in the beginning state in terminal or root#? Now I was in root#
    Last edited by surrapurra; 2011-08-18 at 11:39 AM.
    2011-08-18 11:36 AM
  16. brentondowdy's Avatar
    The whole shebang:
    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=iphone-dump.img

    Just the system partition:
    ssh [email protected] dd if=/dev/rdisk0s1 bs=1M | dd of=iphone-root.img

    Just the user data partition:
    ssh [email protected] dd if=/dev/rdisk0s2s1 bs=1M | dd of=iphone-user.img
    I know this is a really old thread, but I was down this same road and apparently made a big mistake trying to follow these instructions. I wanted to share my failure for anyone who stumbled across this thread, like I did, in hopes of saving them my same mistake. I borrowed the code above for "The whole shebang" and when I executed it, nothing happened and I couldn't find any start of an iphone-dump.img on my computer. I was brain fried and since this was an old phone I decided to give up for a while and leave it. When I came back, my iPhone was alerting me that I had no free space left. (The phone was wiped and only had factory or jailbreak content before this attempt). Whatever I did, I think I reversed where that iphone-dump.img was being sent and loaded up my phone instead. I can only assume this means it has written over all of the freespace that contained the deleted data I was after. It was long fight, but I think I'm throwing in the towel. Here is what I did in terminal in case some one can avoid whatever I did wrong:

    Brentons-Old-iPhone:~ root# ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=iphone-dump.img
    [email protected]'s password:

    dd: writing to `iphone-dump.img': No space left on device
    27747857+0 records in
    27747856+0 records out
    14206902272 bytes (14 GB) copied, 5892.24 s, 2.4 MB/s
    Brentons-Old-iPhone:~ root#
    Brentons-Old-iPhone:~ root#
    Brentons-Old-iPhone:~ root#

    I had read so many threads for hours on end, I'm afraid I probably combined some solutions by accident. I'm typing this at the end of my brain power and as a white flag before I lose motivation to think about it again. Hope this helps somebody.

    Best of luck,
    2012-04-01 04:45 AM
  17. Ceyo14's Avatar
    Has anyone tried this recently. Im trying to do this on an iphone 4 running ios 5.0.1 but keep getting an error. I dont have umount. I tried to copy it from an android but it cant execute the umount binary. The only thing left is to try the mount -o ro command. Ill try it tomorrow. But wanted an update on this...
    2012-07-05 02:35 AM
37 12

Tags for this Thread