1. feffe's Avatar
    I have a big problem. Used iphone for a couple of days. Dont know really what caused this. Installed a couple of programs. A theme that didnt show?! a terminal, openssh etc. But after a reboot this happen.

    [ame="http://www.youtube.com/watch?v=dsEsZJ3I9Pw"]YouTube - iphone stuck in a loop[/ame]




    Really cant do anything with the phone. But... I can login via ssh over wifi.
    Ive noticed "crashdump" runs everytime it reloads the home screen. Im trying to locate a logfile or something to see what ever it is thats causing this.
    Sure a recovery will do it. The phone came with 1.1.3. If I do a recovery iTunes will download 1.1.4. To unlock 1.1.4 I need to change bootloader. How can I do that when I only can access the phone via ssh? Dont really know what to do here
    Best thing would be if I can repair it in the terminal. Without a recovery.


    Any suggestions???




    EDIT

    Copied over all log files then cleared /var/logs/crashreaporter. Then 3 new files showed up. Must be something in there.
    Seems theese two programs crash. Can i remove them from iphone via ssh?
    Is it launchd that runs program on startup? Then it should be possible to comment out some programs that u don whant to start. Help here would be very much appriciated!!!

    Process: SpringBoard [170]
    Path: /System/Library/CoreServices/SpringBoard.app/SpringBoard

    Process: ptpd [167]
    Path: /usr/libexec/ptpd

    http://feffe.ath.cx/ptpd-2008-03-15-123113.plist
    http://feffe.ath.cx/SpringBoard-2008-03-15-123114.plist
    Last edited by feffe; 2008-03-15 at 04:32 PM.
    2008-03-15 12:58 PM
  2. amnesic's Avatar
    Do you try to use the std "passwd" unix command ? If yes you need to reinstall the master password file I guess ... search in forum, there is some solution about this classic problem.

    Hope this helps.
    2008-03-15 04:24 PM
  3. feffe's Avatar
    Do you try to use the std "passwd" unix command ? If yes you need to reinstall the master password file I guess ... search in forum, there is some solution about this classic problem.

    Hope this helps.

    Yes a mather of fact I did change the passwd. It crossed my mind so I change back to default passwd witch was "alpine". Didnt help. U think the file is corrupt or what?
    2008-03-15 04:26 PM
  4. amnesic's Avatar
    yes the /etc/master.passwd is corrupt. you need to reinstall a the original one.
    2008-03-15 08:02 PM
  5. feffe's Avatar
    Anyone with 1.1.3 who could send me passwd files? PM me please!
    2008-03-15 09:30 PM
  6. feffe's Avatar
    Solved the problem by recover and ziPhone. But I did find out what caused it since same thing happende after the restore. I changed passwd and rebooted imiadiatley. As told by amnesic. If you change passwd on the system by using "passwd" command this happens. Dont know if theres a fix for this?
    2008-03-18 03:50 PM
  7. GlennMiller's Avatar
    I'v got the same problem.
    First I changed the password.
    Then I tryed to syncronize outlook.
    At the end of syncronize I got the error message something like "IPhone closed the connection"
    Then I changed the password back to alpine, didn't help with syncronize
    Then I rebootet the device.
    After the reebot the Iphone got caught in the loop.

    Now I would like to restore the factory settings but Itunes is not seeing the device ( Also Windows is not seeing it)
    The device is connectetd over USB to the computer but the operating system is not seeing it.
    Im a newbie in Iphone issues (I have it just few days)
    Could somebody help me ?
    2008-05-04 03:07 AM
LINK TO POST COPIED TO CLIPBOARD