1. memnoch_thedevil's Avatar
    I have a 3GS that is updated to 3.1...long story short, search my name for that issue.

    I also have a 3G, that I gave to my wife, it is on 3.01 or 3.0 I forget, it is jailbroken still, and fine.

    Well I started getting the "this accessory does not work for this device" on my 3GS, and it finally went away. Now it does nothing. I can turn the phone off while plugged into the pc, and it will charge, I can plug the phone into the wall, and it will charge. But the pc does not see the iPhone, neither does iTunes.

    Now my wifes iPhone is similar. The PC and iTunes do not see the iPhone, but at least the charging icon shows up on the phone, and it can be charged while on.

    I have tried both phones with 3 different computers with the same results.

    PC 1 = iTunes 9 + 9.01 + 8.2 & Windows 7 Ultimate x64

    PC 2 = iTunes 9 + 9.01 + 8.2 + Windows Vista Ultimate 32 Bit

    Pc 3 = iTunes 9 + 9.01 + 8.2 + Windows 7 Ultimate x64

    I have an appointment this coming Tuesday at the Apple Store to replace my 3GS. Is there anything that can be done before that time?

    I have unsuccessfully tried to downgrade to 3.0 before this with Saurik's cache server, but for what ever reason it does not work. I get error 1604 message in DFU and instant error 20 in recovery.

    That is not the issue at this time, because now I can not even connect the phone to the computer at all. I kind of think that iTunes some how botched my USB connection on the phone...and my wifes.

    Any hope here, as my phone can be replaced, but hers can not.

    Thanks!
    2009-09-25 10:19 PM
  2. Madman604x's Avatar
    uninstal and reinstal itunes first.

    modify your hosts file to point at Saurik's server.

    put your phone into recovery mode then attempt a (SHIFT+restore) choosing your 3.0 firmware. Make sure you are using the 3GS firmware for your 3GS and NOT a 3G fW.

    if iTunes still doesn't recognize your phone (in recovery mode)its probably time for a trip to the Apple Store.

    there is a tiny possibility that Saurik's server may NOT have captured your ECID info adn is falsely reporting it as true.
    2009-09-26 01:20 AM
LINK TO POST COPIED TO CLIPBOARD