1. Hoody_s13's Avatar
    Hey everyone,

    First real post here and I'm looking for a little help with the iphone visual voicemail.

    I've been running a jailbroken 3GS for a while now but realised a while after that I no longer recieved visual voicemail or any type of voicemail notification. One of those issues that has bugged me, but I keep forgetting to jump on and post anything about it.

    Just restored to 3.1.2 and re-jailbroken with the release of geohots blackra1n and noticed I had 3 Visual voicemail notifications. Brilliant, so it wasnt the jailbreak itself after all. I used pkgbackup to restore the cydia apps I used before, and now its gone again.

    What happens now is I click on the voicemail icon in phone and it dials up my voicemail straight away. Compared to in the past displaying a menu with details on each message I had, and the choice to play/delete messages.

    Without going through one by one and deleting applications to find the problem, can anyone help out or point me in the right direction? I tried disabling all themes in winterboard which didnt fix the problem, so im not sure exactly where to go.

    Heres a list of the apps I have installd (per pkgbackup):

    Action Menu
    Action Menu Plus Pack
    Autolock SBSettings
    AppSync for OS 3.1

    Base Structure
    basic-cmds

    Categories
    Cydia Community Sources
    CyDelete
    Calculator Widget
    diskdev-cmds
    Dev-Team

    **********
    iElegance PRO
    iFile
    Iphone Firmware
    iBlacklist
    iWipe

    libxml2 library

    MakeItMine
    MobileTerminal
    Memtool

    Notifier

    OpenSSH

    Stumbler Plus
    Safari Download Manager
    SQLite 3.x Library

    UserAgent Faker

    Vodafone AU GPRS Fix
    vlc4iphone

    YourTube

    3G Unrestrictor


    Thanks for reading, hope someone knows whats happening here.


    -Rhys
    Last edited by Hoody_s13; 2009-10-12 at 01:03 PM.
    2009-10-12 12:57 PM
  2. tjfitz7's Avatar
    This has happened to me to, but usually I go into the phone app then go to voicemail and then hit the home button then a couple of seconds later it asks me for my voicemail password and then I get it back, but one time I also had to reset the settings by going to: Settings>General>Reset>Reset Network Settings. Hope that helps
    2009-10-12 04:13 PM
  3. Hoody_s13's Avatar
    Ive tried that with no luck, after posting this topic I tried a little more searching and only found more topics with questions unanswered.

    Should I find a visual voicemail setting under Settings>General>Network>Cellular Data Network? Only have voicemail and MMS, possibly the Vodafone AU GPRS Fix which gave me acccess to Cellular Data Network options caused this problem...
    2009-10-12 09:33 PM
  4. one1's Avatar
    TURN WIFI OFF......... remove the sim, reboot, install the sim, wait 3 minutes to 5 minutes, try to access voicemail, attempt to dial out a call, connect and hang up, then reboot. remember that visual voicemail will take up to 5 minutes to kick in once you restart your phone on fresh settings (like after a pwn).

    What you are doing above is making the phone recognize it is on the network. A lot of times you are connected through wifi when booting up and it cannot get cellular data for some items that way. make sure wifi is off.
    2009-10-12 09:42 PM
  5. Hoody_s13's Avatar
    Tried your method but no luck, same symptoms. The moment I click the voicemail icon in Phone, it starts dialing my voicemail. Any other ideas?
    2009-10-13 10:18 AM
  6. StealthBravo's Avatar
    Install the 6.0 carrier settings in the MMS thread in my signature. It will set your visual voicemail settings to default.
    2009-10-13 10:43 AM
  7. Hoody_s13's Avatar
    I'm with Vodafone Australia, will the AT&T Carrier bundle work?
    2009-10-13 12:13 PM
  8. imlachg1's Avatar
    I also had the voicemail problem for a couple of weeks and tried calling voicemail and resetting settings. Once I deleted the tetherimg profile Visual Voicemail worked fine. (Settings > General > Profiles delete the tethering profile) Hope this helps.
    2009-10-13 04:50 PM
  9. burdell1's Avatar
    Is there a way to enable visual voicemail on an iPhone when I'm using a AT&T non-iPhone account?
    2009-10-13 05:15 PM
  10. Hoody_s13's Avatar
    I tried going to settings>general>profiles, but I don't have a profiles section in there? I'm using a 3gs on 3.1.2.

    As for the carrier bundle, I found the latest Vodafone au carrier bundle, installed, rebooted, still nothing. It's a strange one

    I tried going to settings>general>profiles, but I don't have a profiles section in there? I'm using a 3gs on 3.1.2.

    As for the carrier bundle, I found the latest Vodafone au carrier bundle, installed, rebooted, still nothing. It's a strange one
    Last edited by Hoody_s13; 2009-10-14 at 12:17 AM. Reason: Automerged Doublepost
    2009-10-14 12:17 AM
  11. mahgninnuc93's Avatar
    I had this same problem. I ended up having to re-jailbreak it with a "good" firmware. Unfortunately this was the only way I got mine back up and running.
    2009-10-15 05:21 PM
  12. hacktarded1's Avatar
    Same issue here! So annoyed. I also do not have Settings>General>Profiles. No profiles! WTF?!? Any thoughts on other ways to remove tethering profile as that seems to be the issue for most. Any ways to SSH into phone and delete the file? Location of that file? Any help is appreciated.
    2009-10-21 05:18 PM
  13. URPREY's Avatar
    I ended up restoring again and setting up as a new phone. This was the only fix I found unfortunately.
    2009-10-21 05:26 PM
  14. massimuzzo's Avatar
    try settings>general>reset>reset all settings
    2009-10-21 05:39 PM
  15. hacktarded1's Avatar
    Will setting up as a new phone lose all contact info? If so, this is not an option for me, would take me way too long to recover everything!

    Tried settings>general>reset>reset all settings and it did not work. Have alos tried resetting voicemail password and several other AT&T fixes, still not working and I am not even jailbroken right now which confirms to me that the issue was not the blackra1n jailbreak.

    Any other thoughts?

    I do not want to have to setup as a new phone as the loss of all my data would be too painful to recover from . HELP!!!
    2009-10-22 06:30 AM
  16. br8thw8's Avatar
    I'm having similar problems. Right now I have an iPhone 3GS running 3.1.2 and it is NOT jailbroken or unlocked. I am in the US on AT&T. I too have lost VVM, it automatically dials VM like the olden days. I too don't have the option of: Settings>General>Network>Cellular Data Network so I can't edit the APN and nor do I have the option of: Settings>General>Profiles so there is no "tethering" profile to delete. I've tried Resetting the Network Settings and also All Settings. I have restored my iPhone from scratch but have also reloaded the backup so I wouldn't lose anything. Nothing has solved this issue. If I go to the length of setting my phone as a new phone is there a way to get my backup restored too, or is that also restoring the problem? Thanks for any help.
    2009-10-24 09:17 AM
  17. Gemballa500's Avatar
    I found I had this exact problem, I'm on a 2G running 3.0 jailbroken.
    Everything worked fine after I jailbroke except the VVM. I just fixed my problem by first going to SETTINGS < GENERAL < RESET < RESET NETWORK SETTINGS.

    The phone will restart then wait 3 minutes call your iphone from another phone and leave yourself a test message. Shortly you should get that message and VVM should be back to normal.
    Hope this works for everyone as it did for me
    2009-10-25 09:46 PM
  18. Melech518's Avatar
    Just download the latest carrier update, reset all network settings, and call your carrier and ask them to send a signal to the phone...
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME
    2009-10-26 02:43 AM
LINK TO POST COPIED TO CLIPBOARD