1. zeros's Avatar
    I reeeeeeeeely wanted to use pwnage tool heh heh
    2009-11-08 08:18 PM
  2. cpjr's Avatar
    Its not going to work.
    2009-11-08 08:20 PM
  3. zeros's Avatar
    Its not going to work.
    it did work, it made a custom ipsw and everything

    Last edited by zeros; 2009-11-08 at 08:31 PM.
    2009-11-08 08:25 PM
  4. cpjr's Avatar
    Well then congrats because your the ONLY person to EVER get Pwnage tool to run successfully in VMware. Thats why everyone with a Winbox cant build custom IPSW's
    2009-11-08 08:31 PM
  5. zeros's Avatar
    should I write directions? it took me like 2 days to get it working

    fist get vmware server, it's free but you have to register to get a key to activate it

    VMware Server, Free VMware Download for Virtual Server Consolidation

    then get the voodoo2_alpha3_intel kernel (I needed this for my intel q9300)

    xnu-dev - Project Hosting on Google Code

    then you need this which has a bunch of stuff in it


    first you have to activate intel virtualization technology (aka vt)
    you must have a computer capable of this or you can't run vmware
    heres a list of processors
    Intel Virtualization Technology List
    to activate the feature you have to boot your computer into your bios, usually by pressing F2 at startup
    look around in the menus for the option, once it's activated then vmware will install

    next install vmware server, fiarly straightfowared

    now extract the vmware-darwin-200 file and hightlight and copy the path to the folder in the addres bar

    now in your start menu goto all programs->accessories

    right click command prompt and choose run as administrator

    now type cd then hit space then right click the window and hit paste, it should paste the path to where you copied the file

    press enter

    nowt type "setup.cmd install"

    it will put some darwin file in your vmware folder so you can install osx

    then you need to create the osx virtual machine so open the vmware server homepage and login

    once you are logged in you should be able to click create virtual machine to the right

    choose a name, i just named mine osx

    then choose the operating system, select other operating system and choose freeBSD 64

    now choose your memory, I put in 1024 so it had a gig of memory

    I left it at 1 processor, I hear it works fine with 2 though

    now on hard disk click create a new virtual disk

    capacity I choose 20 gigs, if you don't make it enough you wont have enough space to install osx heh heh

    now on virtual device mode change it to ide 0, leave device to 0

    click next

    click add network adapter

    just click next

    on cd dvd choose use physical drive

    choose the disk drive you want to use to install osx from (daemon tool drives do work btw, just make sure it's active before you started vmware, if not reboot your computer)

    virtual device node I chose ide 0 and device 1

    click next

    click don't add a floppy drive

    click add a usb controller, I have'nt been able to get usb to work yet but may as well as add it

    then click next and finish

    you should see the virtual machine pop up to the left now

    so just start the virtual machine and stop it, it will make a bunch of files you have to edit

    now goto your virtual machines folder, I think the default is cvirtual machines

    I belive you set this when you install vmware

    edit the vmx file with notepad or whatever

    look for guestOS =

    make it guestOS = "darwin-64"

    now add these to the bottom of the file

    ich7m.present = "TRUE"
    smc.present = "FALSE"
    keyboard.vusb.enable = "FALSE"
    mouse.vusb.enable = "FALSE"
    monitor.virtual_exec = "hardware"
    monitor.virtual_mmu = "software"

    all this is outlined in the manual.pdf file in the darwin-200 folder you extracted

    okay, now save the file and close and return to the vmware server window

    put in your leopard osx disk

    click the little play icon at the top to start your server again

    then click console and click to open the console window

    okay now I had problems here it kept crashing for me

    click the little menu at the top to restart press c to boot from dvd if it asks then jam on the f8 key to get a little boot prompt

    now I had to put in

    rd(0,1)/mach_kernel.voodoo.alpha3 -v rd=disk1s3

    then the installer worked

    you will have to use the disk tool in the osx installer to make a osx disk on the virtual hard drive

    osx should install now once it was done though it crashed some more, I had to do the f8 thing again and type this in

    rd(0,1)/mach_kernel.voodoo.alpha3 -v rd=disk0s2

    this is outlined in the voodoo.pdf file you shoudl have in the darwin-200 folder

    and it FINALLY booted to the desktop YAY!

    so I immediately opened safari to download pwnage tool soon as it finished it crashed. NOOO not again

    okay this frustrated me to no end finally I figured it out

    so I downloaded this and extracted it on my computer


    then uploaded the extracted file to a website to download with safari on the mac osx

    remmeber, I could'nt get usb to read a hard drive

    I moved it to the root folder and tried editing the file indicated in the voodoo.pdf file


    however I could'nt save the file >

    so I opened the terminal and typed this in

    sudo pico /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

    and edited the file with the pico editor heh heh

    heres where I had lots of problems again, I could'nt figure out how get it to load the right kernel file
    the command in the voodoo.pdf did'nt work

    after messing around with it I finally figured out how

    I made it all look like this

    <key>Kernel Flags</key>

    I rebooted the box and it FINALLY loaded the updated kernel properly

    okay, so now I tried downloading pwnage tool AGAIN and it did'nt crash! it just showed up on the desktop yay!

    I dragged it to my applications folder and ran it, expecting it to crash again or something, but it did'nt. it just opened perfectly

    so then I opened safari again and downloaded the ipsw file from here
    iPod and iPhone Firmware Download

    ran pwnage tool and it worked, it left a custom restore file on my vmware osx desktop

    okay so now I was stuck again, how the hell do I get it out of osx and onto my windows box

    the devices thing for usb did'nt work, coud'nt open any of my external drives

    so my solution was filesharing

    just went into system preferences and checked file sharing

    I created a new windows share and added the account noting the IP listed

    dragged the custom_restore to the share folder and then connected with my windows and transfered the file to my other computer that had itunes on it

    I was doing this for a friend and had his 3g here tried to restore with the ipsw but it did'nt work gave me a 1600 error

    so I downloaded iREB and ran that, then itunes let me restore, his phone rebooted and it had cydia on it

    okay I wrote this from memory, I know a lot of it is probly missing parts and stuff, in no way is this for the average computer user
    this worked perfectly on my computer with an intel q9300 and an intel DP45SG motherboard.

    I'm told the voodoo kernel is only needed for the core2 quad and core i7 processors so you may be able to get it working without doing any of that stuff

    this is what worked for my machine, I'm sure everybody will have to do different stuff for different machines but I'm just reporting what I did here
    search the internet, there are a lot of people trying to get osx to work on vmware and lots of help and tips everywhere, thats how I was able to figure all this out
    Last edited by zeros; 2009-11-08 at 09:40 PM. Reason: Automerged Doublepost
    2009-11-08 09:35 PM
  6. Kapolani's Avatar
    You don't even have to do all that.

    You can just download VMWARE player. Then, look for a vmare image with mac os x on it (10.5.5 is what I got) and create the virtual machine.

    Download pwnage tool then install.

    Good to go after that.

    I created the custom ipsw, just haven't decided if I want to upgrade yet.

    Windows XP
    2009-11-24 03:41 AM