1. benfilan's Avatar
    when i try to add music to the iphone, it says "could not sync music. the disk could not be written from or written to'

    BUT

    photos, video, contacts and bookmarks all sync fine.

    any ideas guys???
    i'm completely stuck! please help!
    2007-09-26 03:32 AM
  2. Kitsune's Avatar
    Try disabling auto-sync and manually selecting songs and playlists. As well as 'rebooting' your iPhone and Computer.
    2007-09-26 03:40 AM
  3. benfilan's Avatar
    didnt work. same error message.
    2007-09-26 03:43 AM
  4. Kitsune's Avatar
    Okay, question. Are you using a USB hub or are you directly connecting to the motherboard? If the former, try connecting to your computer directly, as this can sometimes be a power issue through USB or if you are not using USB 2.0, though that is probably not the case here.
    2007-09-26 03:46 AM
  5. benfilan's Avatar
    using my macbook. directly connected.
    2007-09-26 03:46 AM
  6. Kitsune's Avatar
    I'm still looking into it. Most of what I am reading deals with power issues and that getting a new one wouldn't help either. One person suggested a restore, but the individual couldn't do that. You can try if you want, but other than that I am still researching and balancing studying. I'll do what I can.
    2007-09-26 03:50 AM
  7. benfilan's Avatar
    thankyou!!
    i just installed apptapp, and now in itunes there are no tabs, just the summary page for the iphone, and the option to restore. confusing!
    2007-09-26 03:52 AM
  8. Kyle Matthews's Avatar
    Yah I'm guessing you just tried to sync without rejailing after using some old tools. Do the restore, and you'll be fine.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-26 03:55 AM
  9. benfilan's Avatar
    itunes wont let me restore.

    'an unknown error occured'
    2007-09-26 03:59 AM
  10. Kyle Matthews's Avatar
    What were you doing? Is the download of the firmware complete?
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-26 03:59 AM
  11. Kitsune's Avatar
    This is exactly what the other person stated happened in my research. Won't even let you restore. Try either updating to a newer iTunes or finding a Windows computer to use. I had an issue with being unable to restore, but as soon as I went to the other OS, it worked.

    These are just suggestions.

    Read this too:
    http://docs.info.apple.com/article.html?artnum=301267
    2007-09-26 04:01 AM
  12. benfilan's Avatar
    the iphone works PERFECTLY, minus the ipod part and being able to restore. when i try to sync music, itunes says 'the disk cannot be written to or read from'
    when i try to restore 'an unknown error occured'

    i am using itunes version 7.4.2 and iphone firmware 1.0.2

    and for reference, i am using Mac OSX 10.4.10
    Last edited by benfilan; 2007-09-26 at 04:08 AM. Reason: Automerged Doublepost
    2007-09-26 04:06 AM
  13. Kyle Matthews's Avatar
    Yah I would do as Kitsune is saying, and try a restore on a diff computer.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-09-26 04:07 AM
  14. Kitsune's Avatar
    Once you get the issue working via another OS, in this case Windows, you should, pending it does get fixed, be able to go back to OS X immediately, so you won't have to worry about being stuck with Windows.
    2007-09-26 04:09 AM
  15. benfilan's Avatar
    ok, well my dad uses an imac with bootcamp, i could try it on his tomorrow. basically if i restore on another machine, i'll still be able to go back to using my macbook once thats done?
    2007-09-26 04:18 AM
  16. Kitsune's Avatar
    Yes. I actually have my iPhone jailbreak'ed through both XP and OS X (iBrickr and iFuntastic), so you can use both at the same time.
    2007-09-26 04:23 AM
  17. benfilan's Avatar
    trying to restore at the minute. hopefully it'll work after that.
    2007-09-26 10:40 PM
  18. dbrown85's Avatar
    I actually am having the same problem. I recently modded my iphone via the guides and tutorials provided on the site and when I originally restored, all my music was lost but I was not worried because I thought I would be able to quickly add it back on but I am getting the same error message. I am using a MacBook with OS X. Please help, sorry to be such a noob.

    UPDATE: Nevermind about that, I think I fixed the problem. My music is all sync'ing right now. What I did:

    -I followed all the tutorials listed on the site and then I was having the problem about disc error or whatever.
    -I went to the summary tab on iTunes about the iPhone and checked the "sync only selected songs and videos" in options.
    -Now it works!

    I guess a simple solution to a bothersome problem.

    Any questions, don't hesistate to ask.

    ^
    l
    l
    Thought I got it to work, and then at the end it said "the device timed out". Arg.....any help?
    Last edited by dbrown85; 2007-09-28 at 01:25 AM. Reason: Automerged Doublepost
    2007-09-28 12:52 AM
  19. benfilan's Avatar
    i FINALLY got mine to work!!!

    what i did was restore the machine in windows, used ibrickr to unshackle it, connected it to my mac, re-faux-activated it, and it worked perfectly.

    that was going from syncing no music at all to syncing practially everything i wanted.

    still no idea what caused the problem, which is a bit irksome.
    remember to turn off the internets when restoring, you dont want 1.1.1 firmware if you have modded your iphone at all!
    2007-09-30 05:04 AM
LINK TO POST COPIED TO CLIPBOARD