1. t1mmy23's Avatar
    Ok. It seems a little too late, but this thread appears unsolved.

    Those of you who where able to flawlessly SSH into your hacktivated iPhones in the past, but recently became unable to do so, most likely got infected with the "ikee" worm. In the following link there's a nice interview with the author of the worm, explaining why and how he did it, and how to get rid of it.

    JD's Thoughts on Everything.: Interview with ikee (iPhone Virus Creator) - ikee virus removal details enclosed

    I'm one of those who didn't RTFM and got the worm. Today I found this link and could get rid of the worm. Now I'm back to normal SSH.

    Whatever you do, don't forget to change your iPhone root password.

    Good luck!!
    This worked flawlessly for me!!
    So you have to download ifile or some other file explorer to delete the following files (if some aren't there just ignore that one):
    /bin/poc-bbot
    /bin/sshpass
    /var/log/youcanbeclosertogod.jpg
    /var/mobile/LockBackground.jpg
    /System/Library/LaunchDaemons/com.ikey.bbot.plist
    /var/lock/bbot.lock

    Then just reboot the device and reinstall OpenSSH

    And yeah don't forget to change your password!! I found really straight forward instructions here:
    How To Change the iPhone’s Root Password | iSource

    ENJOY!!
    2010-11-27 02:22 AM
  2. tekkens774's Avatar
    I use ifunbox to ssh. Works good
    2010-11-28 01:25 AM
  3. LennyTheDub's Avatar
    Don't know if this helps, but the last time I had issues, I went into the fugu settings and deleted the history of devices and started again. Can't remember now exactly, but the keychain sounds familiar.

    Hope that helps.
    2010-11-28 03:16 AM
  4. sandytrinh's Avatar
    I've had the same problem but solved it by doing a few things

    1. Settings > wifi > click on the blue button next to your wifi > scroll down renew lease
    2. Reinstalled OpenSSH
    3. Opened up Terminal (can be through MAC HD > APPLICATIONS > UTILITIES > TERMINAL)
    4. Typed in ssh [email protected] (change the 10.0.0.4 into your own IP)
    pressed enter and ta-daaa cyber duck now works for me

    Goodluck! please let me know how it goes for you guys
    2011-05-05 05:00 AM
  5. JarJarTee's Avatar
    Had big problems connecting with cyberduck on iphone 4. Tried any configuration under the sun, so downloaded Fugu, turned WPA security off and hey presto I'm in !! (iPhone4 - Greenpois0n 4.3.2) , used port 22

    OK here's the deal folks, turn of all security on router, connect Cyberduck/Fugu (both in turn if you've got them) - bookmark connection and Quit. Put security back on router - all works brilliantly . I have now tried this 3 times; computer on/off etc-seems to stick
    2011-06-13 12:09 AM
  6. RandomSausage's Avatar
    Try this
    Transmit 4.1.7
    [HELP] Can't anymore SSH into iPhone with Cyberduck/Fugu-getting-into-iphone-transmit.png
    2012-10-13 02:15 PM
  7. leetut's Avatar
    I've had the same problem but solved it by doing a few things

    1. Settings > wifi > click on the blue button next to your wifi > scroll down renew lease
    2. Reinstalled OpenSSH
    3. Opened up Terminal (can be through MAC HD > APPLICATIONS > UTILITIES > TERMINAL)
    4. Typed in ssh [email protected] (change the 10.0.0.4 into your own IP)
    pressed enter and ta-daaa cyber duck now works for me

    Goodluck! please let me know how it goes for you guys
    after typing ssh [email protected] it just moves down to the next line?
    doesnt even ask for a password or do anything

    this stopped working for me 2 years ago!
    sometimes i can connect with cyberduck after pressing try again 50-100 times!
    tried fugu, worked a few times but now its the same
    tried transmit, worked once! but now is the same

    cyberduck is keep saying host is down, host is openssh?

    wish id stayed on windows...
    2013-03-20 07:38 PM
27 12
LINK TO POST COPIED TO CLIPBOARD