User Tag List

  1. Migital's Avatar
    I'm not sure when this happened, as I don't regularly use the video record feature of my iPhone 3GS, but it's often enough that I'd miss having it. When I went to use it yesterday I noticed that the switch at the bottom of the Camera app is no longer there. I can't switch into video mode without it!

    I immediately went into winterboard and shut off just the themes I was using, resprang, and it still isn't appearing. I tried shutting off EVERYTHING in winterboard, resprang, and nothing. I tried the same methods, except doing a hard reset instead of respringing, and still nothing.

    I've tried searching for anything on the internet that might tell me a plist that I need to edit in order to reactivate this function, but all I keep finding is stuff about how to get the video record on the 2G/3G models.

    The M68AP.plist already contains the "video-camera" boolean, so beyond that, I don't know what else I can do. Does anyone know what I can do to restore this function? The internet is not helping me with this at all, but I CAN'T be the only person this has happened to, can I?

    By the way, this is my first time posting, but most definitely not my first time on the board. This community has unknowingly helped me out plenty of times, so hopefully this will be no exception. Any help you can give me is much appreciated!

    The instructions I found for activating video recording on the 2G/3G are as follows
    Now if you want the video recording software to work then by all means go to your M68AP.plist in and add in boolean "video-camera" and set it to 1 for yes in the capabilities dictionary. Presto! You get the video camera software.
    I assume that, because I have a 3GS, the same steps for activating recording on the firmware for the 2G/3G should still apply. Am I right in thinking that?

    I also noticed that I no longer have the option to upload to youtube in the camera roll. Furthermore, I had downloaded an app from the appstore called "Video Stabilizer" specifically for the 3GS, and when I open it, it says that my device is not compatible. This tells me that, somewhere in the phone, it's no longer marked as a 3GS.

    I realize this isn't a quick "google the answer and post a link" type of fix, and requires some real effort to solve the problem, but isn't there ANYBODY on here with some inkling as to what the problem might be?

    Nevermind, I figured it out.

    The problem was in the N88AP.plist.
    I changed:
    Not really sure how the hell it was changed in the first place, maybe I had accidentally done it when I disabled voice commands in the same file. Either way, it's fixed, I have all the capabilities back, and now the answer is online in case anyone else screws this up.
    Last edited by Migital; 2010-03-04 at 05:03 PM. Reason: Automerged Doublepost
    2010-03-04 05:03 PM
  2. soulthoughts's Avatar
    Thanks for posting your solution.
    2010-03-04 07:22 PM