1. Remember God's Avatar
    i have had my iphone jailbroken with blackra1n for a few weeks now and ll of a sudden my internet tethering doesnt work now...the the option to tether is still there but it just doesnt do it, i can turn it on/off but it doesnt actually connect? what gives?
    any ideas on how to fix this?

    not sure if this happened after or before the latest cydia update as i havent used internet tethering for a couple of weeks, but i know it was working after jailbreaking, and worked for a couple of weeks, i know that for sure.
    it may have happened after i had the visual voicemail activated with vodafone the other day (as i had the iphone replaced a month ago), i had to restore the network settings.
    not sure when i lost internet tethering, but how do i get it back?
    i live in australia and am with vodafone so have internet tethering officially on the phone. this same thing happened to my last iphone 3gs, this one i have now is a replacement.
    ive now put on MyWi and tethering works fine through that, why doesnt the normal tethering option work anymore?

    any assistance would be greatly appreciated!!!
    Last edited by Remember God; 2010-03-12 at 10:41 PM.
    2010-03-12 09:34 AM
  2. Remember God's Avatar
    i worked out my tethering problem...
    the "tethering sbsettings toggle" add-on causes problems with the iphones native tethering toggle, sometimes the native toggle (settings>general>network>tethering) doesnt turn on or off when u use the "tethering sbsettings toggle" addon. it can cause loss in tether capability for usb and bluetooth, it can also make the native tether disappear all together (i found if the native tether disappeared and i went to sbsettings and turned the tethering toggle on then off a few times the native tether option would re-appear but it still would not connect to the mac). so i deleted this addon then did a full settings reset and my tethering connection came back. i had full function for both usb and blutooth tethering, just to be sure this addon was the cause i reinstalled it and sure enough the same problem occured..so i deleted and reset again...and everything works as normal.
    i tried the other addon "tether toggle" (apposed to the faulty "tethering toggle")sbsetting and this works fine no problem it synced with the native toggle flawlessly so far and i have had no problems....

    so anyone with loss of tethering after a jailbreak, if you use sbsettings and use "tethering toggle" addon get rid of it reset settings and use "tether toggle" addon.

    finally 4days of near sleeplessness computering and its solved!!! for me anyways!!! good luck to anyone else with similar issues i hope this helps.
    2010-03-14 09:05 AM