1. snum1fan's Avatar
    I have searched and searched and searched this site and the internet in general and have found some people with the same problem but nothing that helps me.

    I have a 3Gs old boot rom jailbroken and unlocked. I have been using it since blackrain came out with absolutly 0 problems.

    Recently I noticed that my Iphone will charge using the wall plug, but when I hook my Iphone up to ANY computer it is not recognized in Itunes or device manager.

    My Ipod touch, Girlfriends 3GS, and now my Ipad work 100% perfect on my computer.

    I have tried my Iphone on my netbook and my gf computer and it will not work on them either.

    So far I have done the following. Nothing has helped.

    Uninstalled and re installed Itunes including mobile device, drivers Quicktime and everything else Apple related that was on there.

    Tried to take a picture before and when hooked up and looking for an entry under cameras in device manager as was reccomended in an Apple thread and on theyre site.

    Tried every USB port on all three computers.

    Cleaned the contacts on the 30 pin connector on the Iphone many times. Inspected them with a light and magnafying glass and they look fine.

    Checked and made sure the Iphone driver is installed.

    Checked and made sure Apple mobile device and Ipod helper was running when trying to get Iphone to connect.

    If I turn the Iphone off then hook it to the computer it will turn on but Itunes will not open and it will not connect.

    Tried hard resetting the Iphone.

    Reset all settings on Iphone.

    Tried with airplane mode on.

    When I put the phone in DFU or recovery mode Itunes will open up and say it has detected and Iphone in recovery mode. I brought it out of recovery mode to see if it would connect and it wouldnt.

    I downloaded a good 3.1.2 firmware and made it so I could resotre through it by directing Itunes to verify the firmware with Cydia instead of Apple. (I have SHSH stored on Cydia). When I did this It went through the verify part succesfully and it would say "preparing Iphone for restore" After this it says Cannot restore Iphone error 1604.

    I tried this restore many times and same thing. I did some digging and error 1604 is some kind of USB malfunction error code.

    Has anyone had this problem to this extent and fixed it?

    ANY and ALL info, suggestions, help is SO greatly appreciated.

    2010-04-05 09:10 AM
  2. snum1fan's Avatar
    Anyone? Please
    2010-04-08 01:01 AM