1. aubinit's Avatar
    Mods -- I searched this forum before posting however did not find anything. I've also spent about 2 weeks now searching Google with no success. If this post is in the wrong place, please move it rather than delete (I read your sticky and this seemed like the best place to post).

    ---------

    Hello All,

    I am relatively new to the iPhone scene however am pretty tech savy; this does not appear to be a simple issue so I'd truly appreciate it if some more advanced users (mods?) could take a look and provide some suggestions.

    I have a 16GB iPhone running 1.1.4 which has been jailbroken & unlocked via ziphones 2.5.

    Everything is working properly EXCEPT video play-back. I do not know if the codecs or the actual player are corrupted however performing a full restore does not correct the problem. I have tried going down to 1.1.3 and the same issue exists; not sure if this is a manufacturer defect / memory issue or something which I can fix myself. I have only had the phone for about 1 month and have always had the problem (however I did unlock / jailbreak manually at one point which bricked the phone; I successfully unbricked it, restored and ran ziphone; this is where I'm at today).

    The video player "works" however the picture has either thick pink bars covering half of the screen or a checkered pink squares across the screen. This problem effects ALL videos; YouTube streaming, video's loaded via iTunes, videos downloaded via MxTube.

    I have attached several pictures showing the problem if the above description does not make sense...

    This appears to be a software related issue because my video driver is fully functional for all other applications (games, iPod music playback, SpringBoard, etc). However, it is quite confusing to be as any software issues should be resolved by performing a full restore (right?).

    I tried taking the phone to apple for an exchange; the 'tech' looked at the phone, said I had to restore it the he'd test it, if problem existed after the restore he'd swap out the phone... That would have been a great solution however unfortunately I am not an AT&T customer (t-mobile); once he learned this he refused to do the exchange (as there was no way for me to activate the phone after restore without jailbreaking) ... I also called Apple's tech support, the tech repeatedly asked for my phone number which I dodged for the first 5-10 minutes as I picked his brain about the issue... He suggested restoring the phone and setting it up as a new phone in iTunes in case my settings were corrupted this would prevent them from being copied back on to the phone. No dice...

    At this point I'm at my wits end and have come up with a few possible solutions, I'd appreciate your feedback in determining which route to take...

    1.) Use another iPhone (my wife's) to copy the video codec or player files onto my PC then onto my iPhone over-writing the potentially corrupted files. Problem is I do not know where these files are located and am somewhat fearful of bricking the phone doing this...

    2.) Somehow (don't know how) perform a low-level format of the phone's entire memory (ROM + RAM + FLASH) and perform a factory restore.

    3.) Wait a few months for CorePlayer for iPhone to be released, purchase it and try it out...

    4.) Sign up for an AT&T prepaid plan, walk into Apple with prepaid SIM in my phone and try swapping out the phone as an AT&T 'customer'... Am somewhat fearful of going this route as I'd like to avoid any problems that could potentially arise.


    Thanks for reading... Your 2 cents is appreciated.
    Attached Thumbnails Corrupted video player / codec - Restore does not fix-pic6.jpg   Corrupted video player / codec - Restore does not fix-pic1.jpg   Corrupted video player / codec - Restore does not fix-pic2.jpg   Corrupted video player / codec - Restore does not fix-pic3.jpg   Corrupted video player / codec - Restore does not fix-pic4.jpg   Corrupted video player / codec - Restore does not fix-pic5.jpg  
    2008-03-17 06:25 AM
  2. xjimb0's Avatar
    I just had this issue too. Except mine played perfectly, no issues with youtube or my own videos. after I installed bsd subsystems i got this error "this movie could not be played" and this goes for everything, youtube streaming also.

    nevermind, i did a reset of all settings and it works now. try that?
    Last edited by xjimb0; 2008-03-18 at 09:50 AM. Reason: Automerged Doublepost
    2008-03-18 09:50 AM
  3. aubinit's Avatar
    Hi xjimb0,

    Thanks for the reply. I tried resetting as suggested; unfortunately the problem still exists.

    Does anyone know if the itunes media player on the iPhone is contained within the firmware & stored on FLASH or if it is contained in the system ROM ?

    If it is in the system ROM and corrupted I fear I'm SOL...

    If the media player is contained in the firmware, does anyone know if it is consistently written to the same memory locations in all firmware versions (1.0.2 <--> 1.1.4).

    The reason I ask is that I starting to suspect this is a hardware issue in that the memory location controlling video play back is corrupted hence causing the error...

    Thoughts? Suggestions?
    2008-03-20 03:33 AM
LINK TO POST COPIED TO CLIPBOARD