1. vegeto2k2222's Avatar
    I have a iPhone 3GS running on firmware 3.1.3. It was jailbroken and I tried to unlock it using blacksn0w from Cydia. While it was installing, my phone froze and it looked like it was going into safe mode (that rotating circle thing appeared), but it ended up freezing. I held the power button and home button to restart it but now it's just frozen on the apple logo every time I try to turn it on.

    I tried putting it into DFU mode by:

    1. Having iTunes turned on.
    2. Holding the power and home button to turn off the phone
    3. As soon as the screen turns black I release the power button but continue to hold the home button.
    4. iTunes says the phone is now in recovery mode (but the screen is just blank, that iTunes logo and usb image are not on the screen)

    Then when I go to restore it, I just receive an error.

    It's been like this for about 4 hours.

    Please help, I don't know what to do.
    Last edited by vegeto2k2222; 2010-06-13 at 06:29 AM.
    2010-06-13 06:13 AM
  2. sgt.pepper's Avatar
    keep on tryin, look up the error on google on what to do. what errror is it?


    13 recovery mode restores
    7 dfu mode restores
    2 custom firmware restores
    2010-06-13 06:27 AM
  3. vegeto2k2222's Avatar
    I am trying to restore it using a custom firmware created by pwnagetool. I am trying it again, but the screen is still blank eventhough iTunes is saying the phone is in recovery mode. Then when I go to restore, an error message saying "The iPhone "iPhone" could not be restored. An unknown error occurred (1600)."
    2010-06-13 06:37 AM
  4. sgt.pepper's Avatar
    heres how to do fix that. it should have everything covered



    13 recovery mode restores
    7 dfu mode restores
    2 custom firmware restores
    2010-06-13 06:57 AM
  5. vegeto2k2222's Avatar
    Wow, thanks a lot for your help. I'm going to give it a try right now...I hope it works.
    2010-06-13 07:01 AM
  6. sgt.pepper's Avatar
    no proeblem dude thats what im here for. tell me if it works or not


    13 recovery mode restores
    7 dfu mode restores
    2 custom firmware restores
    2010-06-13 07:24 AM
  7. vegeto2k2222's Avatar
    This method doesn't seem to work. There's a tutorial once you download the app that sends you to this youtube video:

    [ame=http://www.youtube.com/watch?v=bITIiGswjFI]YouTube - How To: Enter DFU Mode on an iPhone/iPod Touch[/ame]

    and reading the comments on there everyone says it doesn't work on iPhone 3G (dunno if they meant 3GS as well).

    Edit: Upon further investigation I don't think iReb works for 3GS

    So I tried to restore using the official version of 3.1.3 and it appeared to work...my screen turned white and iTunes wasn't reporting the normal errors that I had been seeing.

    I stopped it immediately though because I really don't want to upgrade to 3.1.3 through iTunes because I don't want to upgrade my baseband since I want to be able to unlock it.

    I created a custom firmware of 3.1.3 using pwnagetool but it didn't work.

    Please can someone provide some insight as to what to do?
    Last edited by vegeto2k2222; 2010-06-13 at 10:10 AM. Reason: Automerged Doublepost
    2010-06-13 10:10 AM
  8. confucious's Avatar
    What FW / BB were you on? Was your phone JB / Unlocked before? If so, how?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-06-13 02:04 PM
  9. vegeto2k2222's Avatar
    Thanks for taking the time to help, but I ended up just upgrading it through iTunes and jailbreaking it again...

    Guess I'm gonna have to wait until the dev team releases an unlock tool (hopefully that'll be on the 24th!)
    2010-06-13 10:30 PM
  10. Bakakage's Avatar
    Too bad you ended up using stock. Just to let you know for reference, the Cydia version of blacksn0w has many problems. What you needed to use was Blacksn0w RC2 Final from the cydia.pushfix.info repo. I'm actually selling my iphone tomorrow and the buyer wanted it unlocked, so I restored to a CW 3.1.3 I downloaded (I did not make it) to keep my 5.11.07 baseband. After restoring I did not have a signal but after using RC2 final I got it back and zero problems so far.
    2010-06-14 02:07 PM