1. maddawg05's Avatar
    Hope this is the right place to post this. Bought a used 3GS 32GB. So far everything works but the ring. Phone will not ring when a call comes in. Just vibrates (not stuck on vibrate because it turns off when I silence the vibrate option). Speakers work find on everything including when I pick the ringtone. The switch on the top right clicks and swithes over to ring and shows the speaker icon when I switch from vibrate to ring. Doesn't ring in the headset when I have it hooked up when I tried to call it. Secondly, when I tested it out using another phone, I would call it, hang up on the other phone and my iphone still shows it calling for at least 45 seconds after.

    Very discouraging buying used electronic. I noticed a small crack on the plastic, near chrome switch. Out of ideas.
    2010-06-19 06:13 PM
  2. i.Annie's Avatar
    Did you restore the phone before using?

    What firmware and baseband is it on? Do you need an unlock? The best thing you can do is restore, but it is a bit complicated on a 3GS. You will have to find out some things about the phone if you need an unlock. If not, you can restore/upgrade to 3.1.3.

    If you do need the unlock, find out your firmware and baseband and your bootrom version for better guidance on this process.
    2010-06-19 06:22 PM
  3. maddawg05's Avatar
    Reset to factory....Tried EVERYTHING. Figured it out when I restore to previous backup there were ringtones I got from cydia and for some reason it saved that assignment from my wife (that's who's phone I was calling to test it out). I changed the ringtone assignment for my wife and worked. The cydia ringtone didn't transfered just the title. Hopefully my explanation makes some since.
    2010-06-19 07:10 PM
  4. iTone's Avatar
    A crack, and no ringtone, and a lagging ring?

    Sounds like it got droppped, and was just working enough for the seller to find someone who would buy it, and then he/she could claim ignorance.

    Buy a Baseball bat and ask for refund.

    Seriously though- I am thinking a couple of issues. The crack and the lagging notifier sounds weird, but for the ringtone:

    When you go into settings and choose a ringtone, does the selected ringtone ring- do you hear it in settings mode?

    If not, could just be that the original ringtone file has been corrupted, or even changed to be silent.

    If it does sample when you choose it in settings, it sounds like a hardware problem, but iof you get sound through SMS etc it isnt your speakers.

    My bet would be a corrupted sound file- have you tried several ringtones?

    If you got your wifes assigned ringtone and it worked, my bet is either the aforementioned corruppted ringtone, or you are missing a plugin from Cydia which is required to recognise the sound file.

    If you can see:

    if it works in settings ?
    if it works when you locate and preview it in your SSH program?

    ....Then we can keep troubleshooting this badboy.
    2010-06-19 08:41 PM