User Tag List

  1. tc250's Avatar
    I tried jailbreaking my iPhone 3GS 3.1.2 with redsn0w. I followed the instructions on iClarified but there was a part that said:

    "Step Six
    RedSn0w will ask you if this is a newer (fixed) model iPhone. Newer models of the iPhone 3GS have a fixed bootrom which requires you to connect your device to the computer each time you wish to reboot.

    To find your serial number you can follow these instructions. The week number is usually the 4th and 5th digit of the serial number. For example, a serial number beginning with 88926 would be week 26 of 2009. 3GS units made week 45 or later will usually have a fixed bootroom. Before week 40 they usually have the older bootroom. Between weeks 40 and 45 the results vary.

    If you believe your device has a fixed bootrom then press the Yes button. Otherwise press the No button.

    If you accidentally select the wrong option you may have to do a full restore so please make this choice carefully."

    My phone was made on the 43rd week. So "the results vary". I went was Yes. My phone then was stuck in Recovery Mode. I tried it again but with "No". After it was finished my screen was just black. I could turn the phone on and iTunes would recognize it in recovery mode, but the screen is just black. I tried to do an official restore, and a 3.1.2 restore but I simply get the message:
    "The iPhone "iPhone" could not be restored. This device isn't eligible for the requested build."

    Anyway to fix this?
    2010-06-28 11:13 AM
  2. xYurjevich's Avatar
    Use Blackra1n.
    2010-06-28 12:19 PM
  3. tc250's Avatar
    I've tried Blackra1n. It goes "waiting for device...", and doesn't go any further.

    any other suggestions?
    Last edited by tc250; 2010-06-28 at 11:01 PM. Reason: Automerged Doublepost
    2010-06-28 11:01 PM