1. mmurphmsu's Avatar
    I work for a University in North Texas. We have a campus wide WiFi network that has the same SSID and Paraphrase. Once these are entered, and the user brings up a web page, he/she is forced to log in with a user name and password.

    Here is my problem. With my old 3G phone I was able to do this no problem. But with my i4, I accept the certificate and then it acts like it is going to connect to the captive portal, then kills Safari. Anyone have ideas on what is going on??? It is something to do with the phone, because other IS people with the 3Gs and iOS 4 don't have the problem.

    I have spoken with Apple support and they told me to update to 4.0.1 and that didn't fix my problem. They told me to restore to new if that didn't fix it, I did and it still doesn't work.

    I have an appt at an Apple store on Saturday to get the phone looked at. I hope they just replace it.
    Last edited by mmurphmsu; 2010-07-20 at 07:29 PM. Reason: Automerged Doublepost
    Please hit "Thanks!" if I helped you.
    2010-07-20 07:29 PM
  2. mmurphmsu's Avatar
    Got a brand new phone Saturday at the Apple store in Frisco, tried it this morning at work and it still crashes after I accept the server certificate. So it must be a Safari issue. I am gonna call Apple again on my lunch break and see what they say.
    Please hit "Thanks!" if I helped you.
    2010-07-26 05:19 PM
  3. iNeo's Avatar
    wow it seems whenever you call apple for help now they just tell you to update to there latest version
    2010-07-26 05:37 PM
  4. mmurphmsu's Avatar
    Well I did a google search on safari crashes with iphone 4 and found this thread: [ame=http://forums.macrumors.com/showthread.php?t=961863]iPhone 4 Safari crashes when accessing internet at school - Mac Forums[/ame]

    Turning off Autofill fixed my issue.
    Please hit "Thanks!" if I helped you.
    2010-07-26 06:08 PM