1. rafsterman's Avatar
    Hi there,

    I have a jailbroken 3gs (3.1.3) which is synced to iTunes on my netbook.

    I now also have an iPhone4 that will replace the 3gs. My question is, how can I recover the saved app information in my iTunes (aNote save data the most important) and transfer over to my iPhone4?

    When I connect my iPhone4 to iTunes on my netbook I get the following message:
    The iPhone "iPhone" cannot be used because it requires iTunes version 9.2 or later.

    My understanding is that the latest version of iTunes is needed for syncing with iPhone4 and also that you can only sync one iPhone per iTunes instance - is this right?

    Does anybody have any ideas or suggestions how I'll be able to transfer my app data to my new iPhone4?

    Thanks in advance for your help.
    2010-07-24 06:07 PM
  2. jkmonkey's Avatar
    Yes ios 4.x requires iTunes 9.2 or higher. Just update your iTunes so the iPhone 4 can sync. When you connect the 4 if you choose the restore from previous backup and select the backup from your 3GS it'll carry over all your app saves. You can sync as many iPhones/iPods to the same iTunes as you want. I have 6 idevices that sync to my iTunes.
    2010-07-24 11:03 PM
  3. rafsterman's Avatar
    @jkmonkey
    Thanks for the response. Yes I guess it makes sense that an iTunes upgrade would keep your backed up data. I didn't know you could transfer your data to another device so thanks for clearing that up.

    My only concern with upgrading to iTunes 9.2.1 is that last month dev-team said to stay clear if your iPhone is jailbroken by Spirit which mine is (was done prior to 9.2 being made available though).

    Any thoughts on this?

    Thanks again.
    2010-07-24 11:22 PM
  4. jkmonkey's Avatar
    It won't cause a problem syncing a device that's jailbroken with spirit. 9.2 causes a problem when you try to run spirit to do the jailbreak, but there's a modified version of spirit that works with 9.2 anyway. So you shouldn't worry about updating iTunes.
    2010-07-25 02:07 AM
  5. John1177's Avatar
    It won't cause a problem syncing a device that's jailbroken with spirit. 9.2 causes a problem when you try to run spirit to do the jailbreak, but there's a modified version of spirit that works with 9.2 anyway. So you shouldn't worry about updating iTunes.
    I didn't know there was an updated version of spirit. Do you still have to re-jailbreak with the updated spirit before you can upgrade and jailbreak to 4.0?
    2010-07-25 03:26 AM
  6. jkmonkey's Avatar
    The updated/modified spirit I'm talking about just makes it able to work with itunes 9.2, its still only for 3.1.x fw. I was just letting you know about that so you know its ok to upgrade itunes, it wont affect the jailbreak on your 3gs. But to answer your question about if you have to jailbreak before upgrading and jailbreaking 4.0, the answer is no, the first spirit was a stand alone jb which didn't require you to be previously jailbroken. I'm guessing when the new one is released it'll be the same way.
    2010-07-25 03:30 PM
LINK TO POST COPIED TO CLIPBOARD