1. SilentEcho13's Avatar
    I have a 32gb iPhone 4 running iOS 4.0, recently jailbroken. I initially had the missing FaceTime and mms but installed the fix from cydia.

    Today I synced my phone and I keep getting the "SMS mailbox full" prompt asking me to delete messages.

    I went on and deleted atleast 1000 messages but I still get the error. A respring, reset, and a power cycle don't seem to fix the problem.

    I'm able to send messages and people receive them, but I can't receive any responses.

    I have sent nowhere near 75000 messages either.

    Is there anything I can do to fix this issue?

    Thank you!

    screenshot:

    Last edited by SilentEcho13; 2010-08-07 at 04:44 AM. Reason: Automerged Doublepost
    2010-08-07 04:44 AM
  2. piston597's Avatar
    Try a dfu restore, and don't back up from the old backup, maybe theres a problem there.
    2010-08-07 04:51 AM
  3. SilentEcho13's Avatar
    Upon SSHing into the phone, the sms folder, i saw a file called "sms.db.sg1bak" that wasn't there before. I tried deleting it, but it didn't help :/

    I can't afford to restore at the moment either
    2010-08-07 05:02 AM
  4. SilentEcho13's Avatar
    I can definitely give that a shot.

    I have my database opened in SQLite Database Browser for OSX right now actually, and I have 92,316 rows...lol

    How can I vacuum the database?
    2010-08-07 06:11 AM
LINK TO POST COPIED TO CLIPBOARD