1. Smoked_tails's Avatar
    i remember having this problem before its quite annoying! I do the convert to aac, rename m4r or whatever, drag to itunes, but it will only add one of them to my phone. I can have two, if i delete the one that comes up, then the other will go. but on the phone under ringtones, i cannot get more then one to show up is this a common problem or??? I have a new iphone 4..
    2010-08-07 04:39 AM
  2. Malakov08's Avatar
    Thats interesting, because i have done both the m4r method and the garageband method through a mac and have multiple custom ringtones. So, from what I gather, when you add them to your itunes library...are they both showing under the ringtones page? This is odd. I will test this and get back with you.
    2010-08-07 05:24 AM
  3. Smoked_tails's Avatar
    Yes they are both on there, and if i recall this happen to me before. tonight it started, i had the same song, (different partS) so they had the same name, so i was for sure that was it, then i deleted it and re did it with two different songs and only one will pop up, most annoying this ever

    in other words, if i have two ringtones on itunes that are "suppse to be on the phone" I go to the phone only one shows up, if i delete the one showing up, it automatically puts the other one, it will never list more then one in the "sounds" thing of the phone
    Last edited by Smoked_tails; 2010-08-07 at 05:33 AM. Reason: Automerged Doublepost
    2010-08-07 05:33 AM
  4. Malakov08's Avatar
    You are trimming it down below 40 seconds right? I Just made two custom ringtones the aac-m4r method and they both show up. Also did another with the same exact file, named differently. All are on the phone. Had to restart settings for it to show up. Forgive me, its getting a bit late and i'm going to test one last thing in the morning. Hang in there.
    Last edited by Malakov08; 2010-08-07 at 06:25 AM. Reason: read double post
    2010-08-07 05:46 AM
  5. Smoked_tails's Avatar
    Yea i actually do them below 30 secnds, like 22-23 most of the time, i remeber having the same issue on my 3gs before too, so annoying

    Let me make sure im doing this right.. U edit the song FIRST? Then convert aac, then open in explorer, then rename , then drag to phone right??

    In ringtones, on itunes, i UNCHECK the one that is on my phone, and the one below it is checked, i push sync and the unchecked one STILL stays on the phone, and the other doesnt come up. I have to right click and push delete for the other one to actually show up. and i have checked "sync the ones with boxes checked" whatever it says
    Last edited by Smoked_tails; 2010-08-07 at 07:56 PM. Reason: Automerged Doublepost
    2010-08-07 07:56 PM
  6. Malakov08's Avatar
    Last edited by Malakov08; 2010-08-07 at 08:12 PM. Reason: Messed up
    2010-08-07 08:03 PM
  7. Smoked_tails's Avatar
    Ive read so many guides online now, i do everything exactly right. I tried to deauthorize/ reauthorize etc, nothing. I delete the aac version from my music like another guide said, nothing. Driving me nuts. I have the worst luck with iphones, i dont even know why i went out and bought another one. Even though they are two different complete files, its as if the computer is somehow confusing them for them same thing, only letting one go on the phone. It also seems there is a "dominant" one sometimes that stays no matter what until i actually delete it, ive tried several different songs/files
    2010-08-07 08:20 PM
  8. Malakov08's Avatar
    I was about to suggest Deauth/reauth ... This makes things more fun. When I hop home I'm going to drop them into the phone via SSH. and then you'll try it.
    2010-08-07 08:29 PM
  9. Smoked_tails's Avatar
    kool, let me know appreciate the help. i really did not want to restore my phone the second day ive owned it over a stupid ringtone. They can never make things black/white for this phone always have to jump through stupid hoops
    2010-08-07 08:52 PM
  10. Malakov08's Avatar

    use whatever client you can use to ssh in unless you're comfortable using terminal or command prompt.

    the path for me is /Private/var/Stash and then Ringtones is a subfolder. this drops it in the regular ringtones list as you can tell. I haven't yet tested this, but the guy in that blog says that it does, although it is a bit old.

    the path for the custom ringtones is /User/Media/iTunes_Control/Ringtones.....however When I researched this method of dropping the files in by SSH, it pointed out that you cannot do this because the files aren't actually stored on the phone (?) but on the itunes database. That's why when you look at them they will have odd 4 letter names...even your music and music folders will. I speculate that therefore a simple drop will not show up in the list. My suggestion would be to de-authorize all computers and then try to sync them normally with your main computer as the only one authorized...try this first. (I know its a hassle to go back in and authorize ><). If all else fails, you can always sync your ringtones with ifantastic or whatever it's called...

    I assume that youre jailbroken, and that blog is a bit outdated.. so all you need is openSSH and possibly SBSettings to turn it off.
    Last edited by Malakov08; 2010-08-08 at 12:32 AM. Reason: Automerged Doublepost
    2010-08-08 12:32 AM
  11. Smoked_tails's Avatar
    No actually, my phone is brand new, iphone 4. Ive had bad luck being jailbroken in the past, it seems to always make the phone way less reliable, so im done there. I use it for business and cant afford an unreliable phone. Im really unfamiliar with the whole "ssh" talk?
    This phone has actually only been plugged into one computer ever (besides the one at att where they activated it)

    Well i think i figured it out, i never went to the actual ringtones tab, and selcted sync. Kind of dumb on mypart, but also dumb how apple lets me put one when i drag it, and nothing else comes up. I would usually just rename on desktop and drag to itunes, and it woul say syncing when i drug it over but never went to actual phone. So kind of user error in my part, and stupid software issue on apples part.
    Last edited by Smoked_tails; 2010-08-10 at 04:02 AM. Reason: Automerged Doublepost
    2010-08-10 04:02 AM