1. NYzJatt's Avatar
    I reset network settings on my iphone 4 and now when i connect to my wifi i get full service but when i use a internet program it says it cant connect to the internet. Everything was working fine before i pressed reset network settings.

    Now i dont want to restore because i can activate it afterwards. Any way to fix this problem without restoring.
    2010-08-15 07:58 PM
  2. queinnel's Avatar
    ok. Here is the solution: Go to cydia>> add this source: sinfuliphonerepo.com >>>>> search and install push doctor and push fix inside the source. Reboot >>> that'is your I4 will run as it should be.
    2010-08-15 08:03 PM
  3. NYzJatt's Avatar
    But thats not the problem? i can use everything, only thing that doesnt work is my home wifi. i just connected to someone elses wifi and it worked.
    2010-08-15 08:11 PM
  4. jkmonkey's Avatar
    The either your home network is not connected to the Internet or you may have entered the network key for your wifi incorrectly.
    2010-08-15 08:30 PM
  5. NYzJatt's Avatar
    It definitely connected to the internet because im using the connection right now on my laptop posting this. Ive entered the key multiple times. Im connected to my network but i cant connect to the internet. When it was working well i reset network settings to turn tethering off but now my internet doesnt work and tethering is still on

    I think i know whats the problem. When i look at more info about my network on my iphone theres an IP address and Subnet Mask.

    Router and DNS is blank so how do i figure out what to put for them if thats the problem
    Last edited by NYzJatt; 2010-08-15 at 09:22 PM. Reason: Automerged Doublepost
    2010-08-15 09:22 PM
  6. mbeezy81's Avatar
    It should assign IP addresses automatically, I'd say reboot your router and phone.
    2010-08-15 09:32 PM
  7. jkmonkey's Avatar
    Your phone should get those automatically from your router. Try hitting "forget this network" to completely erase settings on your phone for your wifi. Then reboot and try to reconnect.
    2010-08-15 10:22 PM
  8. NYzJatt's Avatar
    Thanks for the help everybody. I just had to reboot my router and enter the info again.
    2010-08-16 03:10 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.