1. Cmalinowski's Avatar
    Hi. I have an iPhone 3G that my daughter dropped. It worked for a couple months, then died... well, had serious issues. I replaced the glass screen and digitizer screen, along with the home button.

    I turned it on and it seemed to be kind of okay, but is stuck on the apple logo. "No big deal" I thought, I can just restore it. I put it in restore mode, it downloaded and began the restore and then... 1603 error. Ugh.

    I searched the 'net and it seemed that iREB was the tool of choice back in 2007, and even so earlier this year. But iREB is no longer available for download (I was a month late).

    I've tried everything Apple suggests: upgrading to latest iTunes, all sorts of Windows changes, uninstall this, install that. Nothing.

    I've tried other things: uninstalling/downgading iTunes, getting old firmware, tinyUmbrella loop reset, etc.

    I just can get it to not sit on the Apple logo... unless it is in recovery mode where it has the connector image. I have put it in DFU mode and the same thing happens.

    Any help is appreciated. Any other thoughts are appreciated. I can't figure it out anymore, but I believe the phone will work if I could just get a firmware installed on it.

    Thanks,
    Chris
    2010-08-30 09:44 PM
  2. billinaz's Avatar
    after you restore, use recboot to get you out of where it is stuck (Im using windows).
    2010-08-31 04:49 AM
LINK TO POST COPIED TO CLIPBOARD