User Tag List

  1. p13t3rm's Avatar
    Hi everyone, I've searched all over the internet for my 2 problems but couldn't get any relevant/current answers for my device.

    1st Problem: My iPhone 4's tap-to-focus in the camera app does not work at all.

    It use to before I jailbroke but ever since a little after that, it hasn't worked.

    My friend has an iPhone 4 that is jailbroken as well and it is able to tap-to-focus with ease. I don't get it.

    2nd Problem: My Windows 7 Machine does not recognize my iPhone 4 anymore.

    I don't know what happened, but after jailbreaking, my computer refuses to even acknowledge that the device is plugged in to a usb port. iTunes doesn't see it either, obviously.

    Any help would be greatly appreciated, I came here simply because I know someone has the knowhow and the apple forums probably wouldn't be too happy to read i'm jailbroken.

    Thanks!
    2010-09-03 03:34 PM
  2. screamforme02's Avatar
    try a restore and see if the problems go away. than jailbreak. it could have been something happened when you jailbroke. my voice recorder stoped working on my 3g everytime i jailbroke to. very strange
    Hey! A Restore Never Hurts It's True!
    2010-09-03 04:00 PM
  3. p13t3rm's Avatar
    I appreciate the advice, but again, my computer cannot see my iPhone.
    It's as if nothing is even plugged in, no usb connection indicator or anything.
    2010-09-03 04:28 PM
  4. jkmonkey's Avatar
    Put the phone into dfu mode. With the phone connected to your computer hold the home and power buttons so the phone shuts off. Continue holding both buttons for ten seconds, then release the power button. Keep holding the home button for thirty more seconds. The phones screen should now be completely black, not off but black. iTunes will tell you that it has detected an iPhone in recovery mode. From there you'll be able to restore. If you have shsh's saved for 4.0 or 4.0.1 use them to install one of those two so you can jailbreak again. If not you'll just have to do a normal restore, and it will install 4.0.2.
    2010-09-03 04:37 PM
  5. p13t3rm's Avatar
    Thanks for the quick response, Jk.

    Question: I'm not too certain about what shsh's are, When i jailbroke and accessed cydia for the first time, it asked if it wanted me to back them up and i think i did.

    How can i access these?
    Last edited by p13t3rm; 2010-09-03 at 04:55 PM.
    2010-09-03 04:52 PM
  6. jkmonkey's Avatar
    Download and run tiny umbrella. Have it check to see if cydia has shsh's for 4.0.1. If it does then download 4.0.1 from the downloads section of this site. Then click the "start TSS" button on tiny umbrella. Hold shift while clicking restore in iTunes and select the fw you downloaded.
    2010-09-03 04:57 PM
  7. p13t3rm's Avatar
    I was about to thank you jk, but with my luck i figured i'd wait.

    After succesfully putting the iphone in restore mode, i was able to get my computer to recognize it. Unfortunately when I tried restoring from the 4.0.1 firmware i downloaded, it gave me an error (3002).

    I pretty much gave up at that point and decided to try and go with a 4.0.2 install. But even that didn't work. It gave me and error again (1008).

    Aggggh.
    2010-09-03 06:36 PM
  8. jkmonkey's Avatar
    Hmmm I'm having a hard time finding info on either of those errors. Are you clicking on the update button or the restore button?
    2010-09-03 08:59 PM
  9. p13t3rm's Avatar
    At this point the phone is only bootable to the itunes logo restore screen.
    When plugged in to my computer i have the option of restoring it,
    but about 30 seconds after i try i'm given an error prompt.
    "The iPhone cannot be restored at this time because the iPhone software update server could not be contacted or is temporarily unavailable."
    2010-09-03 09:37 PM
  10. Fangor's Avatar
    Go to C:\Windows\System32\Drivers\etc\ and open the hosts file with Notepad. If you see gs.apple.com anywhere, delete it, save the file, restart, and try again.
    Last edited by Fangor; 2010-09-03 at 09:48 PM.
    2010-09-03 09:46 PM
LINK TO POST COPIED TO CLIPBOARD