1. akacipher's Avatar
    My iPhone 2G was on 3.1.2 firmware till last week and I had modified my carrier.plist file so that I can edit the apn field. My data was working fine.

    Then just a couple of weeks back I updated to 3.1.3, used redsn0w to jailbreak and unlock. All went well. Then I installed open SSH from cydia and changed my carrier.plist file again, as expected I can change the APN.

    After changing the APN to what it was on 3.1.2, I am unable to access the data anymore, it says I am not subscribed to cellular data service.

    Just to clear the doubts, I am subscribed to the data service, as my sim can access data through other phone I tried with. Also the apn settings I have re-entered after upgrading are correct. I am in india on vodafone and the APN that used to work was www, I have also tried portalnmms but both dont work anymore.

    I have read through the carrier.plist wiki file and I can verify that all the stuff is correct in the bundle, the only thing I cant understand is the signature tag! I dont know if it was persent in 3.1.2. so guys please help me out.... what am I missing here!!!

    Any help will be largely appreciated.

    Thanks.
    2010-09-26 02:46 PM
LINK TO POST COPIED TO CLIPBOARD