User Tag List

  1. cygmarx's Avatar
    My iPhone was given to me by my best friend because he just got the iPhone4 and before he shipped it to me he said he connected to his home network just fine. MINE is a 3G on iOS 4.0.1 jailbroken with redsn0w and unlocked with ultrasn0w. My carrier is T-Mobile. My PC's OS is Windows 7 Ultimate x64.

    Okay guys I'm a newb here and I've literally spent @ LEAST 20-30 hours online researching, reading countless forum posts, watching video after video just desperately seeking a solution to this very frustrating problem so I'm finally giving in and hoping like hell someone here can finally help me.

    So here's the deal. My iPhone recognizes wireless connections without any issues. It can see my wireless router as well as any other without any difficulty. For the record - my router is a D-Link DIR-655. I've tried everything in my IT knowledge base as well as everyone else's suggestions I've come across and I cannot for the life of me get it to connect to ANY wifi connect even though it detects them effortlessly. I've disabled N and set my router to a/b/g, g alone, set the width to 20Mhz @ Apple's recommendation, I've tried no security whatsoever, I've tried WPA/WPA2, altering the channel, changing the SSID, rebooting it, tried 2 other different routers, tried resetting my Time Warner Cable Motorola Modem - I have seriously been through hell trying to get this thing to connect to WiFi and I've tried every little fix I've encountered short of (Baking? Freezing? lolwut?) the damn thing. I've reset the network settings, restored the phone, tried a few free WiFi networks in public - EVERYTHING - nothing's worked for me so far. Very sad face. The WEIRDEST part of all of this is.. the ONLY time I can get the phone to do anything besides tell me "unable to connect" even to a network without any security is when I set my DIR-655 to WEP - then when I attempt to connect it tells me "incorrect password" every single time no matter what password I type, which is usually the one I have set in the router. I've tried a $ prefix (I think that only applys to Mac users? not sure) but I tried it anyways to no avail! So yea.. the only time I can get it to tell me anything other than "unable to connect" is with WEP encryption (which is horribly unsecure) and even then it continuously tells me "incorrect password."

    I tried connecting it to my router just completely restored with his original AT&T sim card in it and WiFi still didn't wanna work for me. If anyone here has any recommendations that don't involve a freezer, an oven, or a sledgehammer I'll give it a go. I've got excellent computer and network skills and I can provide you guys with any additional information you might need. I would absolutely love to get this figured out because this is the first time in a VERY long time I feel like a piece of technology has made me it's ***** and it's not making me a happy camper. Sorry for the super long post I just wanted to be thorough and I'm seriously losing my mind trying to figure this out. If anyone's got suggestions I am ALL ears. I've done so much searching and I've yet to come across anyone having the exact same issue as me - some similar but none exactly like mine. I'm about to just accept the fact that this phone hates me and sweet sweet wireless internet. Please say it ain't so..

    Hoping for a solution,
    a very sad Mike
    2010-10-17 01:16 PM
  2. MXCO's Avatar
    I had the same problem with my old 3G and I think what it is, is that your wifi wire ripped maybe I think. I never got mine fixed cause I upgraded to ip4. I asked a few stores locally and they all said it could be my wifi wire or something like that. That I had to replace it or something. As far as solutions I don't have any never got around to it.
    "You may say I'm a dreamer, but I'm not"
    2010-10-17 02:15 PM
  3. Captinsmooth's Avatar
    Iphone 3g is known to have wifi hardware issues within the phone. It may be you problem.
    This post infers no rights and is provided as is.

    Click here to follow me on twitter
    2010-10-17 03:57 PM
  4. cygmarx's Avatar
    Yeah, at this point after everything I'd gone through with the phone I pretty much figured it was hardware failure. It still blows my mind that it can detect the networks without any issue it just refuses to connect no matter what I do. I still don't understand why when I set my router's encryption to WEP it seems to *attempt* to connect but continuously tells me the password is wrong.

    I would think if the hardware itself were failing my WiFi wouldn't work at all but I really don't know much about how the iPhone works internally so I'll just accept the fact that it's a failure. Thanks guys.
    2010-10-18 10:46 AM
  5. Coop's Avatar
    It may not necessarily be iphone hardware, since it is recognizing your wifi network. I can try to help if you can answer a few more questions.

    1) what is the signal strength on your iphone?
    2) are you actually using WEP, or something else like WPA or WPA2?
    3) As configured, can you ping your iphone from another PC on the same network?
    4) have you tried to temporarily remove encryption from the wifi router and allow the ihone to connect to an open wifi network?
    2010-10-18 12:56 PM
  6. cygmarx's Avatar
    1) To my home network - 100%. I'm only about 5 feet from the router @ my PC. Others it depends on how close I am to the actual connection but signal strength doesn't seem to be an issue.
    2) Right now I'm using WPA/WPA2. I've tried every combination of security to no avail. No other device has any problem connecting - my wife's G1, laptops, PCs - nothing but the iPhone.
    3) I can't ping the iPhone because it won't connect to the network. How would I go about pinging a device that refuses to connect to my network? I didn't think that was possible. Even when I set the router to WEP and attempt to connect I can see no evidence in my router's log that the iPhone has even attempted to connect, nor do I see any evidence of a connection attempt with no security or WPA/WPA2.
    4) Yes, in my initial post I stated that I'd tried without any encryption whatsoever - still gives me the same "unable to connect" message.
    2010-10-18 01:54 PM
  7. Coop's Avatar
    I have trouble with WPA2, so I've found that WPA works best for me. At least that was the case on earlier iOS versions. Will try now that I'm on 4.1. This just informational for you.

    On your iPhone, try setting up a static route. Go into settings->wifi and find the entry for your network, then select static tab and enter valid ip within range of allowed addresses in your routers config. Include sub net mask, gateway and dns for your Internet service provider.

    Make sure wifi router set for open (no encryption for now), network ip range includes iPhone static ip assignment, speed set to auto negotiation, and no other authentication options active like Mac address authentication. Lastly, make sure SSID broadcast is enabled. Than check if your iPhone will connect and report back here.

    Reboot router and iPhone to make sure your changes stick.
    Last edited by Coop; 2010-10-18 at 05:34 PM.
    2010-10-18 05:31 PM
  8. cygmarx's Avatar
    I've already tried that. Didn't work. I have seriously spent 30-40 hours researching this issue on google and none of the solutions have worked for me.

    I tried everything you suggested just for shits and giggles and it didn't work.
    2010-10-18 05:52 PM
  9. Coop's Avatar
    Before your friend gave you the phone, did he try to erase and reset his info on the phone or did he give to you exactly as he had it configured? I.e. All he did was remove sim and hand to you
    2010-10-18 09:25 PM
  10. cygmarx's Avatar
    He restored it to 4.0.1, right before the 4.1 update was available on iTunes. He also said he connected to his router without any issue after restoring it and before shipping it to me.

    When I got the phone, it was freshly restored with 4.0.1 firmware.
    2010-10-18 09:36 PM
  11. Coop's Avatar
    Do you trust that your friend sold you a good phone? If so, then your phone should be working as-is (based on your response above) and the problem is config related to your router. Just for grins, can you connect to your router with another wireless device?

    I just went back and re-read your original post and saw that you can't connect to any public wifi's either.

    Here's my recommendation --

    Option 1- Ship this back to your friend and have him verify it is working on his router, just to eliminate phone hardware issues. Let him know you can't connect to anything and have tried everything. Get some proof it is working for him.

    Option 2 - Assuming you have SHSH's on file for 4.0.1 (or Cydia has them or your friend can email them to you), then restore FW and re-jail break. Something sounds fubar in your network plist with the phone in current state. Not completely clear from your posts if your friend actually connected to his network AFTER he restored and jailbroke the phone or prior. If for some reason he performed a "reset all" or "erase all content and settings" or "reset network" afterwards and THEN shipped to you, that could be part of the problem. I've had my jailbroken phone end up in an unreliable state after using these options (settings --> general --> reset --> "reset option"). Hence, you should try restoring your phone, jail break and then it should connect right up to your network (assuming DHCP enabled on phone and your router).
    Last edited by Coop; 2010-10-18 at 10:41 PM.
    2010-10-18 10:09 PM
  12. cygmarx's Avatar
    My friend gave me the phone, for free. It's not my router because I've tried 4 other different routers.

    Coop please read my very first post because you keep asking me things I've already stated the answer to. I am not trying to be rude but everything you're suggesting and asking me I've already stated that I've tried it. :P

    I really think something is defective with the wireless hardware of the phone, but I'm just not sure what. I don't understand how the wireless detects networks but just won't connect to them.
    2010-10-18 10:31 PM
  13. Coop's Avatar
    I went back and re-read. Not trying to insult your intelligence, but sometimes people state one thing, but in reality added or omitted a step and didn't mention. Was just trying to get baseline established and trying to eliminate variables.

    Try option 2. That'll at least give you a fresh clean start and eliminate iOS as the possible culprit.

    Also, you already stated it was working fine on on your friends router. If reliable info, then you have to assume your hardware is working fine. If defective, you'd be screwed unless you open the phone and start replacing modular assemblies inside. So you might as well assume it is working and trouble shoot for an error in the network config somewhere. If the hardware is truely working, then a software step has been missed by you (phone or router) or iOS network settings on phone are fubar and a FW refresh is in order.

    BTW, I didn't see anywhere in your posts if you actually connected to your wireless router with another known working device. Do you have any other wireless devices, like a notebook PC, confirmed working? Just because you substited 3 or 4 other routers doesn't mean you should't try connecting with a known good device. Again, sometimes trouble shooting elusive network issues requires an effective process of elimination strategy. You sound IT savvy, so I'm sure you already know this.

    Have you tried turning on logging feature of your DLink router and see if dropped packets from the iphone are listed? That is your first confirmed clue hardware is working, but software in the router is rejecting the request. If no dropped packets, then something else is blocking. Most likely config settings in router for negotiation. Hence all the stuff I mentioned previously. Check the logs and you'll eliminate one and be able to focus on the other.
    Last edited by Coop; 2010-10-18 at 11:57 PM.
    2010-10-18 11:31 PM
  14. cygmarx's Avatar
    Nah it's cool. I understand what you mean I just hate repeating myself.

    Yes, I've got a notebook PC and my wife's G1 that connect to the router without any issues.

    The logging feature of my router - that's where I was looking before when you were talking about pinging the device and I see no record of any connection attempt from the iPhone @ all, regardless of what security setting I use.

    I can't really send the phone back to him because even though WiFi's not functioning correctly, I can't afford to be without a phone for 1-2 weeks just to have him reconfirm the wireless was working with his router. To clarify - he never jailbroke or unlocked the phone for me - I did that. Right before he sent me the phone, he restored it using iTunes to 4.0.1 and I had him connect to his wireless network (he said he connected) and once I received it I jailbroke and unlocked it myself. Even before I jailbroke or unlocked the phone I never could get it to connect to WiFi.

    I just checked my router's log and I'm not seeing any dropped packets after attempting to connect 4 times. I'm not even seeing any packets being sent.

    I tried restoring it and then performing the jailbreak/unlock again last night and that didn't help either.
    2010-10-18 11:59 PM
  15. Coop's Avatar
    FWIW, I have a wireless N router and it works fine with the iPhone. I have a 3GS, a new 4 and the original iphone as well. So I doubt your DLink extreme N is the problem even with N enabled (assuming b and g are on too).

    However, you didn't answer my previous question on turning off security. Specifically, do you have MAC address filtering enabled?

    When you said you dis-abled security, did that include:
    1) WEP (or WPA/WPA2, etc)
    2) MAC filtering
    3) IP filtering
    4) disabling firewall rules
    2010-10-19 12:41 AM
  16. cygmarx's Avatar
    When I say disable security I mean disable security. I'm talking open wireless access with no filtering, no encryption, and no password.

    1. Yes.
    2. Yes.
    3. Yes.
    4. What do you mean by "firewall rules"? Disabling SPI? I've got some NAT endpoint filtering on the router but I've had other iPhones connect to this very same router before without any issues.

    I really don't think it's my router bro because I can't even connect to public WiFi networks that have absolutely no security whatsoever and I've tried 3 other routers here @ home with no results.
    2010-10-19 12:52 AM
  17. Coop's Avatar
    Hey man, sorry I can't be of more assistance then. Sounds like you've done everything. Maybe someone else can chime in and assist.

    What JB method did you use?
    Last edited by Coop; 2010-10-19 at 01:18 AM.
    2010-10-19 01:08 AM
  18. cygmarx's Avatar
    This one: [ame=http://www.youtube.com/watch?v=A05ZNmkQO1I]YouTube - iOS 4 / 4.0.1 / 4.0.2 Jailbreak & Unlock iphone 3g and Jailbreak iPod Touch 2nd gen (NON MC MODEL)[/ame]

    I used redsn0w.
    2010-10-19 01:17 AM
  19. Coop's Avatar
    redsn0w is a pwnage style JB. Did you use custom FW or the stock Apple 4.0.1 FW (no mods at all)?
    -->Edit by Coop: redsn0w is not a pwnage style tool and doesn't use custom FW. Only has some custom options available through the redsn0w iface. It had been awhile since I used it, so I went back and re-checked just to be sure.

    It really sounds like your hardware is working, but you have a config issue on the iphone. I think that is where you should be focusing your effort at this point. Maybe restore and JB again just to start clean could fix.
    Last edited by Coop; 2010-10-19 at 01:57 AM.
    2010-10-19 01:23 AM
  20. cygmarx's Avatar
    I used the stock 4.0.1 firmware.

    I can try limera1n after another restore. Will I still be able to unlock with Ultrasn0w after the jailbreak?
    2010-10-19 01:39 AM
34 12
LINK TO POST COPIED TO CLIPBOARD