1. noforu's Avatar
    Long story short - I f*cked up my iphone, THEN i ssh'd into it and renamed mobilesubstrate.dylib because i thought it would force the phone turn on straight into safemode - didn't work
    so now I'm looking for a way to get into the iphone's filesystem without SSH because it wouldn't connect to it anymore.
    so ATM it's stuck on the apple logo loop (reboot every 1~2 minutes), it's a 3G, costume 4.1 ipsw - old baseband

    So I thought about iREB - how did they mange to load these files from DFU mode? iTunnel maybe? I know nothing about what is and what isn't possiable in DFU mode but im willing to learn
    so PLEASE if you have a way, even the hardest one, to get into the filesystem from dfu mode(/recovery?) please share it with me!
    (no OS limitations - i have a pc/mac/and can install ubuntu)


    Thanks!
    2010-10-31 05:48 PM
  2. iNT3Rv3NTiONZz's Avatar
    Are you trying to avoid a restore? I know that's not what you want to hear but obv since you renamed that dylib it can't reach springboard, that's why iReb won't be working.. As far as I can tell you'll need to restore..

    iPhone4 16gb black - 4.1 Limera1ned
    iPhone 3G 16gb white - 3.1.2 jailbroken
    Blackra1ned
    THANKYOU ONCE AGAIN GEOHOT!
    2010-10-31 09:03 PM
  3. dotFIVE's Avatar
    Restore via PwnageTool custom firmware on 4.1 so you won't lose your unlock.


    Sent from my iPhone using ModMyi
    2010-10-31 09:12 PM
  4. noforu's Avatar
    Well, I've tried restoring to my costum 4.1 and recived 1600/1604 errors, even with iREB.
    I tried before I renamed the file so It's not that im trying to avoid a restore it just seems to me that I cannot restore :[
    2010-11-01 07:29 AM
  5. NakedFaerie's Avatar
    I know its been a while but I just got a fix for this problem WITHOUT restore.
    I have a iPhone and iPad.
    I renamed MobileSubstrate.dylib on the iPad trying to fix a few problems with paid apps.
    The iPad was in an infinite loop at the apple logo.

    Now, for the fix.
    I SSH'd into the iPhone and got the MobileSubstrate.dylib file.
    I copied it into a folder Library\MobileSubstrate so it looks like this \Library\MobileSubstrate\MobileSubstrate.dylib
    I ZIP'd it. Now its a Library.zip file.
    I converted it from ZIP to TAR.GZ using arc_convert052
    I loaded up Redsn0w 0.9.8b1 (Any Redsn0w should work with custom bundles)
    I only loaded up the custom bundle I just made "Library.tar.gz"
    I put the iPad in DFU mode, I started redsn0w and it did its thing.
    The iPad is now alive WITHOUT restore.

    YEAH FOR ME!!!

    Looks like you can do with with just about any file now. If you have the file and the correct path it looks like you can fix any problems.
    Last edited by NakedFaerie; 2011-06-29 at 10:19 AM.
    2011-06-29 10:16 AM
LINK TO POST COPIED TO CLIPBOARD