1. one1's Avatar
    Lately I have gone to take a pic with my iphone and it goes to video camera by default instead of still camera so if I whip it out and swipe for a quick pic it just screws everything up and starts a movie.

    This just started out of nowhere a day or two ago. Any ideas or at least directions on where to edit the default setting?
    2010-11-06 09:17 AM
  2. StealthBravo's Avatar
    Sounds like user error
    2010-11-06 10:39 PM
  3. skiptowncat's Avatar
    mine defaults to whatever I left it on last.
    2010-11-06 10:52 PM
  4. whereswaldo's Avatar
    ^me too
    Name? whereswaldo
    iDevice + Firmware? 32GB Black iPhone 4 iOS 5.0
    Computer + OS? Dell Inspiron 15R 2nd Gen i5, 2.3 Ghz, 750GB HDD, 8GB RAM Windows 7 HP
    Location? Toronto
    Found yet? No
    2010-11-06 11:54 PM
  5. one1's Avatar
    anyone? bueller bueller?

    As my hot rod buddies would say, this forum is a bunch of gold chainers.
    Last edited by one1; 2010-11-08 at 03:00 AM. Reason: Automerged Doublepost
    2010-11-08 03:00 AM
  6. Bo Troxell's Avatar
    As you did, searched and couldn't find anything really that would help.
    Makes me feel bad that no one has been able to help the guy that has helped so many for so many years.
    2010-11-08 03:40 AM
  7. one1's Avatar
    I remember there being snapshot cache files for the iphone to leave ti in it's last state, but I dunno if the camera follows that rule.

    %$#$%^***%@^&#T!!!!!!!!!!!!!!!!!!
    Last edited by one1; 2010-11-09 at 12:21 AM. Reason: Automerged Doublepost
    2010-11-09 12:21 AM
  8. Krome20's Avatar
    I'm having the same issue and so far have had no luck finding a solution. Mine defaults to the video camera and the front facing (webcam) camera.

    Stealth, I don't think it's user error because even after I change it to the still-camera and the lens on the back of the phone and then take a picture, it will always open up to the video camera and webcam.

    I recently installed FastSnap to use the volume buttons to take a picture so maybe that's what caused it. I tried uninstalling it but that didn't help. I also decrypted the iOS 4.1 ipsw and tried replacing all the files on my phone in /System/Library/CoreServices/RawCamera.bundle with the original ones but got the same result. I've looked all over the filesystem but nothing stood out as to what could be causing it.
    2010-11-09 06:30 PM
  9. Piazza331's Avatar
    Mine was doing the same thing. The only way I managed to kick it out of this habit was to open the camera app, switch the slider to camera (from video), take a picture, close the app with the home button, then use remove BG to close all apps. The next time I opened my camera app it defaulted to camera instead of video.
    2010-11-09 09:41 PM
  10. Krome20's Avatar
    I gave that a shot but it didn't work for me. Switched to camera, took a picture, closed it with the home button and killed all open programs with Remove BG from SBsettings but it still opens up to the video camera and the webcam. Thanks for the suggestion though
    2010-11-09 10:06 PM
  11. timmyinpajamas's Avatar
    I'm having the same problems it sucks I just updated to 4.1 today n installed a bunch of things so I don't know what caused it but I'm hoping after I get home a fresh restore will fix it .. Wish me luck

    Ok so for me I had disable multitasking installed n after uninstalling it works normal now
    Last edited by timmyinpajamas; 2010-11-11 at 01:27 AM. Reason: Automerged Doublepost
    2010-11-11 01:27 AM
  12. one1's Avatar
    I restored my phone yesterday to get rid of the issue.

    Glad to know I am not without company on the issue though. That means next time it happens someone might have an answer for everyone since it is going to keep happening.
    2010-11-11 04:01 AM
  13. Krome20's Avatar
    I just restored my phone about two weeks ago and finally finished installing everything and setting everything up the way I like so I don't want to have to do that all over again with another restore. It's not a deal breaker for me since I don't use the camera all that often.

    Timmy, glad you figured out which program was causing the issue and got it resolved.

    I went back and uninstalled my 15 most recent things in Cydia but it didn't fix the issue. Oh well
    2010-11-11 06:12 PM
  14. one1's Avatar
    There were two recent cydia updates that I thought might have done it, but I don't know what my two recent updates were. Basic stuff, not 3rd party or anything.
    2010-11-11 08:21 PM
  15. floppy_joe's Avatar
    Mine was doing it. I also noticed hDR was off when u switched to camera mode after turning hdr then taking a pic now it defaults correctly. So may seem illogical but try cycling hdr on/off
    2010-11-11 10:07 PM
  16. Madman604x's Avatar
    i just stared having this issue too. its replacement iPhone 4 too. the old phone had the same issue before
    60% of the time, it works every time.
    2010-11-24 06:24 AM
  17. Madman604x's Avatar
    For me it was "z toggle" that caused the camera bug. When I turned of native multitasking, the cam always defaulted to the front cam and movie mode. Turn n multirask, and it screwed up the cameras again.
    2011-01-10 07:23 AM
  18. Madman604x's Avatar
    My bad. As long as your cam is set to what you want as default, you can then disable backgrounding and the cam will stay that way. Or coversely, set the cam default and use Backgrounder to keep the default settings.
    2011-01-19 06:04 AM
  19. Krome20's Avatar
    Madman you are amazing!!! I just tried that out and it worked! I opened my camera app and changed it from video camera to still camera and front-facing to rear-facing camera and then held down the home button until Backgrounder said "Backgrounding Enabled". I've tried respringing and rebooting a couple times and now it always goes to the way it should be! (rear-facing, still cam) No more switching it to the regular camera every time I open the app! Thanks again!
    2011-01-19 06:50 AM
  20. jujinz's Avatar
    I had this problem too, very annoying.

    SOLUTION: (for mine at least)

    Install SnapTap from Cydia

    Open camera, select Camera option with the slider and take a picture.

    Close camera and respring iPhone.

    Mine now defaults to camera or video depending on which is selected upon closing the camera app.

    Hope that works for someone else too.
    2011-04-09 12:52 AM
23 12
LINK TO POST COPIED TO CLIPBOARD